summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-19 06:45:51 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-19 06:45:51 +0000
commite72775a88aa67657e53a2c7ea70fab960bfcf972 (patch)
tree8a0c1e1fb6f65b7e6202a1cfac41fcca25b34ba4 /games-strategy
parentversion bump (diff)
downloadgentoo-2-e72775a88aa67657e53a2c7ea70fab960bfcf972.tar.gz
gentoo-2-e72775a88aa67657e53a2c7ea70fab960bfcf972.tar.bz2
gentoo-2-e72775a88aa67657e53a2c7ea70fab960bfcf972.zip
Fix build with gcc-4.5 Bug #320207
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/ChangeLog6
-rw-r--r--games-strategy/widelands/files/widelands-0.0.14-gcc45.patch40
-rw-r--r--games-strategy/widelands/widelands-0.0.14.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index e7368b32f4ab..1ea54b72b064 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.23 2010/01/23 15:39:30 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.24 2010/05/19 06:45:51 tupone Exp $
+
+ 19 May 2010; Tupone Alfredo <tupone@gentoo.org> widelands-0.0.14.ebuild,
+ +files/widelands-0.0.14-gcc45.patch:
+ Fix build with gcc-4.5 Bug #320207 by flameeyes@gentoo.org
23 Jan 2010; Brent Baude <ranger@gentoo.org> widelands-0.0.14.ebuild:
stable ppc, bug 299183
diff --git a/games-strategy/widelands/files/widelands-0.0.14-gcc45.patch b/games-strategy/widelands/files/widelands-0.0.14-gcc45.patch
new file mode 100644
index 000000000000..caefcde969b3
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.0.14-gcc45.patch
@@ -0,0 +1,40 @@
+--- src/editor/ui_menus/editor_main_menu_random_map.cc.old 2010-05-18 17:17:15.000000000 +0200
++++ src/editor/ui_menus/editor_main_menu_random_map.cc 2010-05-18 17:18:29.000000000 +0200
+@@ -251,7 +251,7 @@
+ posx, posy, width, height,
+ g_gr->get_picture(PicMod_UI, "pics/but1.png"),
+ &Main_Menu_New_Random_Map::button_clicked, *this, 8,
+- Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name());
++ Widelands::World(m_worlds[m_currentworld].c_str()).get_name());
+
+ posy += height + spacing + spacing + spacing;
+
+@@ -322,7 +322,7 @@
+ if (m_currentworld == m_worlds.size())
+ m_currentworld = 0;
+ m_world->set_title
+- (Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name());
++ (Widelands::World(m_worlds[m_currentworld].c_str()).get_name());
+ break;
+ case 9:
+ break;
+--- src/editor/ui_menus/editor_main_menu_new_map.cc.old 2010-05-18 17:38:29.000000000 +0200
++++ src/editor/ui_menus/editor_main_menu_new_map.cc 2010-05-18 17:38:55.000000000 +0200
+@@ -113,7 +113,7 @@
+ posx, posy, width, height,
+ g_gr->get_picture(PicMod_UI, "pics/but1.png"),
+ &Main_Menu_New_Map::button_clicked, *this, 4,
+- Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name());
++ Widelands::World(m_worlds[m_currentworld].c_str()).get_name());
+
+ posy += height + spacing + spacing + spacing;
+
+@@ -142,7 +142,7 @@
+ if (m_currentworld == m_worlds.size())
+ m_currentworld = 0;
+ m_world->set_title
+- (Widelands::World::World(m_worlds[m_currentworld].c_str()).get_name
++ (Widelands::World(m_worlds[m_currentworld].c_str()).get_name
+ ());
+ break;
+ }
diff --git a/games-strategy/widelands/widelands-0.0.14.ebuild b/games-strategy/widelands/widelands-0.0.14.ebuild
index b1333b972642..a894953d6208 100644
--- a/games-strategy/widelands/widelands-0.0.14.ebuild
+++ b/games-strategy/widelands/widelands-0.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.0.14.ebuild,v 1.7 2010/01/23 15:39:30 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.0.14.ebuild,v 1.8 2010/05/19 06:45:51 tupone Exp $
EAPI=2
inherit toolchain-funcs eutils versionator games
@@ -32,7 +32,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
sed -i \
-e 's:__ppc__:__PPC__:' src/s2map.cc \