summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-16 12:20:32 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-16 12:20:32 +0000
commit74ba4a2cc70dd37e69a1fada7dc73f9010cd4f7c (patch)
tree26729e60ea61ebf42ad056e8dd7ded3aa6221a63 /games-strategy
parentpunt old, clean up (diff)
downloadgentoo-2-74ba4a2cc70dd37e69a1fada7dc73f9010cd4f7c.tar.gz
gentoo-2-74ba4a2cc70dd37e69a1fada7dc73f9010cd4f7c.tar.bz2
gentoo-2-74ba4a2cc70dd37e69a1fada7dc73f9010cd4f7c.zip
Respect LDFLAGS. Bug #337440
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/dark-oberon/ChangeLog8
-rw-r--r--games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild5
-rw-r--r--games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-ldflags.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/games-strategy/dark-oberon/ChangeLog b/games-strategy/dark-oberon/ChangeLog
index c52e27ae7f56..8a63f324237b 100644
--- a/games-strategy/dark-oberon/ChangeLog
+++ b/games-strategy/dark-oberon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/dark-oberon
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/dark-oberon/ChangeLog,v 1.3 2009/07/17 08:05:57 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/dark-oberon/ChangeLog,v 1.4 2010/09/16 12:20:32 tupone Exp $
+
+ 16 Sep 2010; Tupone Alfredo <tupone@gentoo.org>
+ dark-oberon-1.0.2_rc1.ebuild, +files/dark-oberon-1.0.2_rc1-ldflags.patch:
+ Respect LDFLAGS. Bug #337440 by flameeyes@gentoo.org
17 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org>
dark-oberon-1.0.2_rc1.ebuild:
diff --git a/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild b/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild
index ddceb1dc48d0..0d453dd4509f 100644
--- a/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild
+++ b/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild,v 1.3 2009/07/17 08:05:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild,v 1.4 2010/09/16 12:20:32 tupone Exp $
EAPI=2
inherit games
@@ -27,6 +27,7 @@ S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}/${P}"-gcc41.patch
"${FILESDIR}/${P}"-gentoo.patch
+ "${FILESDIR}"/${P}-ldflags.patch
)
src_compile() {
diff --git a/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-ldflags.patch b/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-ldflags.patch
new file mode 100644
index 000000000000..845a80634320
--- /dev/null
+++ b/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-ldflags.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.old 2010-09-16 14:07:38.000000000 +0200
++++ src/Makefile 2010-09-16 14:07:54.000000000 +0200
+@@ -33,7 +33,7 @@
+ doxygen .doxygen.conf 2>&1 | tee .doxygen.log
+
+ ../dark-oberon: $(OBJECTS)
+- $(CPP) $(OBJECTS) $(LIBPATHS) $(LIBRARIES) -o ../dark-oberon
++ $(CPP) $(LDFLAGS) $(OBJECTS) $(LIBPATHS) $(LIBRARIES) -o ../dark-oberon
+
+ doalloc.o: doalloc.cpp cfg.h doalloc.h dologs.h
+ $(CPP) -c doalloc.cpp