summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-10 03:35:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-10 03:35:30 +0000
commit564cac6e7958008f4f9bddca53eeebef63886ac9 (patch)
tree3909d539cbfb2af472edddf2641f63b9f38ca4a9 /games-strategy
parentadd support for USE=vanilla and create versioned symlinks so people can run `... (diff)
downloadgentoo-2-564cac6e7958008f4f9bddca53eeebef63886ac9.tar.gz
gentoo-2-564cac6e7958008f4f9bddca53eeebef63886ac9.tar.bz2
gentoo-2-564cac6e7958008f4f9bddca53eeebef63886ac9.zip
upstream patch for compile with USE=mysql (bug #101903)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/scorched3d/ChangeLog5
-rw-r--r--games-strategy/scorched3d/scorched3d-39.ebuild12
2 files changed, 15 insertions, 2 deletions
diff --git a/games-strategy/scorched3d/ChangeLog b/games-strategy/scorched3d/ChangeLog
index 26328824d550..40feca2ddaa6 100644
--- a/games-strategy/scorched3d/ChangeLog
+++ b/games-strategy/scorched3d/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/scorched3d
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.22 2005/08/09 00:40:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.23 2005/08/10 03:35:30 mr_bones_ Exp $
+
+ 10 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org> scorched3d-39.ebuild:
+ upstream patch for compile with USE=mysql (bug #101903)
*scorched3d-39 (09 Aug 2005)
diff --git a/games-strategy/scorched3d/scorched3d-39.ebuild b/games-strategy/scorched3d/scorched3d-39.ebuild
index adf90dde995a..117d74f6cbd7 100644
--- a/games-strategy/scorched3d/scorched3d-39.ebuild
+++ b/games-strategy/scorched3d/scorched3d-39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-39.ebuild,v 1.2 2005/08/09 20:52:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-39.ebuild,v 1.3 2005/08/10 03:35:30 mr_bones_ Exp $
inherit wxwidgets games
@@ -32,6 +32,16 @@ pkg_setup() {
games_pkg_setup
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # bug #101903
+ sed -i \
+ -e "s/const possibleChars/const char possibleChars/" \
+ src/common/StatsLoggerMySQL.cpp \
+ || die "sed failed"
+}
+
src_compile() {
# work around portage bug: described in bug #73527
if use gtk2; then