summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-12-20 07:25:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-12-20 07:25:37 +0000
commit0346b55daaddf5c2a190b69c6f80ac03af43f7b6 (patch)
tree952811ea1781e52621d79d9bcc5203f748f0dcef /games-strategy
parentRemove old. (diff)
downloadgentoo-2-0346b55daaddf5c2a190b69c6f80ac03af43f7b6.tar.gz
gentoo-2-0346b55daaddf5c2a190b69c6f80ac03af43f7b6.tar.bz2
gentoo-2-0346b55daaddf5c2a190b69c6f80ac03af43f7b6.zip
Migrate to EAPI=5.
Use QA_PREBUILT as per bug #426836 (Portage version: 2.1.11.38/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/defcon-demo/ChangeLog8
-rw-r--r--games-strategy/defcon-demo/defcon-demo-1.42.ebuild16
2 files changed, 15 insertions, 9 deletions
diff --git a/games-strategy/defcon-demo/ChangeLog b/games-strategy/defcon-demo/ChangeLog
index 65bc92820d8c..29c922c1c055 100644
--- a/games-strategy/defcon-demo/ChangeLog
+++ b/games-strategy/defcon-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/defcon-demo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/defcon-demo/ChangeLog,v 1.5 2011/10/19 21:40:06 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/defcon-demo/ChangeLog,v 1.6 2012/12/20 07:25:37 tupone Exp $
+
+ 20 Dec 2012; Tupone Alfredo <tupone@gentoo.org> defcon-demo-1.42.ebuild:
+ Migrate to EAPI=5.
+ Use QA_PREBUILT as per bug #426836 by Diego
19 Oct 2011; Michael Sterrett <mr_bones_@gentoo.org> defcon-demo-1.42.ebuild:
EAPI=2
diff --git a/games-strategy/defcon-demo/defcon-demo-1.42.ebuild b/games-strategy/defcon-demo/defcon-demo-1.42.ebuild
index 33ae69455017..f09d0614e820 100644
--- a/games-strategy/defcon-demo/defcon-demo-1.42.ebuild
+++ b/games-strategy/defcon-demo/defcon-demo-1.42.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/defcon-demo/defcon-demo-1.42.ebuild,v 1.5 2011/10/19 21:40:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/defcon-demo/defcon-demo-1.42.ebuild,v 1.6 2012/12/20 07:25:37 tupone Exp $
-EAPI=2
+EAPI=5
inherit eutils toolchain-funcs games
MY_PN=defcon
@@ -32,6 +32,8 @@ RDEPEND=">=sys-libs/glibc-2.3
x11-libs/libXdmcp"
DEPEND=""
+QA_PREBUILT="${GAMES_PREFIX_OPT:1}/${PN}/lib/defcon.bin.x86"
+
S=${WORKDIR}/${MY_P}
src_prepare() {
@@ -49,23 +51,23 @@ src_prepare() {
}
src_compile() {
- $(tc-getCC) -fPIC -shared -ldl -o lib/chdir.so chdir.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c || die
}
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
insinto "${dir}/lib"
- doins lib/*.dat || die
+ doins lib/*.dat
exeinto "${dir}"/lib
- doexe lib/*.{sh,x86,so} || die
+ doexe lib/*.{sh,x86,so}
dodoc manual.pdf doc/*txt
doicon doc/defcon.ico
# Can be upgraded to full version, so is not installed as "demo"
- dogamesbin "${T}"/defcon || die "dogamesbin failed"
+ dogamesbin "${T}"/defcon
make_desktop_entry ${MY_PN} "Defcon" /usr/share/pixmaps/defcon.ico
prepgamesdirs