summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-10-19 08:32:16 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-10-19 08:32:16 +0000
commitda3d1c553ff4b6e28394df9fb9c9a884aecdcfc0 (patch)
tree5441e41c42fab229c7479c2a8fdbcd061d4756de /games-strategy/wargus
parentadded prefix support (bug #435576) (diff)
downloadgentoo-2-da3d1c553ff4b6e28394df9fb9c9a884aecdcfc0.tar.gz
gentoo-2-da3d1c553ff4b6e28394df9fb9c9a884aecdcfc0.tar.bz2
gentoo-2-da3d1c553ff4b6e28394df9fb9c9a884aecdcfc0.zip
version bump
(Portage version: 2.2.0_alpha140/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-strategy/wargus')
-rw-r--r--games-strategy/wargus/ChangeLog7
-rw-r--r--games-strategy/wargus/wargus-2.2.7.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/games-strategy/wargus/ChangeLog b/games-strategy/wargus/ChangeLog
index cc2b2e237660..63d5e4c69604 100644
--- a/games-strategy/wargus/ChangeLog
+++ b/games-strategy/wargus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wargus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/ChangeLog,v 1.24 2012/06/06 19:36:35 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/ChangeLog,v 1.25 2012/10/19 08:32:15 hasufell Exp $
+
+*wargus-2.2.7 (19 Oct 2012)
+
+ 19 Oct 2012; Julian Ospald <hasufell@gentoo.org> +wargus-2.2.7.ebuild:
+ version bump
06 Jun 2012; Julian Ospald <hasufell@gentoo.org> metadata.xml:
set myself as maintainer
diff --git a/games-strategy/wargus/wargus-2.2.7.ebuild b/games-strategy/wargus/wargus-2.2.7.ebuild
new file mode 100644
index 000000000000..8af3f9fa7987
--- /dev/null
+++ b/games-strategy/wargus/wargus-2.2.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/wargus-2.2.7.ebuild,v 1.1 2012/10/19 08:32:16 hasufell Exp $
+
+EAPI=4
+
+inherit eutils cmake-utils gnome2-utils games
+
+DESCRIPTION="Warcraft II for the Stratagus game engine"
+HOMEPAGE="http://wargus.sourceforge.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=games-engines/stratagus-${PV}*[theora]
+ media-libs/freetype
+ media-libs/libpng:0
+ sys-libs/zlib
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="games-strategy/wargus-data"
+
+S=${WORKDIR}/${PN}_${PV}.orig
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${GAMES_BINDIR}"
+ -DBINDIR="${GAMES_BINDIR}"
+ -DSTRATAGUS="${GAMES_BINDIR}"/stratagus
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "Enabling OpenGL in-game seems to cause segfaults/crashes."
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}