summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-02 19:01:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-02 19:01:33 +0000
commit4b4525ea40294a78666ea2c5a917e494802f9789 (patch)
tree45f141b0203b780ca3bfa8507c456d9251a92fdd /games-strategy/uqm
parentDrop old and add a comment to last 0.5 version to check in next bump with par... (diff)
downloadgentoo-2-4b4525ea40294a78666ea2c5a917e494802f9789.tar.gz
gentoo-2-4b4525ea40294a78666ea2c5a917e494802f9789.tar.bz2
gentoo-2-4b4525ea40294a78666ea2c5a917e494802f9789.zip
old
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/uqm')
-rw-r--r--games-strategy/uqm/ChangeLog5
-rw-r--r--games-strategy/uqm/uqm-0.6.2.ebuild130
2 files changed, 4 insertions, 131 deletions
diff --git a/games-strategy/uqm/ChangeLog b/games-strategy/uqm/ChangeLog
index 554ec3a28b80..56eef4ba5381 100644
--- a/games-strategy/uqm/ChangeLog
+++ b/games-strategy/uqm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/uqm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.34 2012/07/02 08:58:45 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.35 2012/07/02 19:01:33 mr_bones_ Exp $
+
+ 02 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org> -uqm-0.6.2.ebuild:
+ old
02 Jul 2012; Jeff Horelick <jdhore@gentoo.org> uqm-0.7.0-r1.ebuild:
marked x86 per bug 424467
diff --git a/games-strategy/uqm/uqm-0.6.2.ebuild b/games-strategy/uqm/uqm-0.6.2.ebuild
deleted file mode 100644
index 72f5a20ce1f6..000000000000
--- a/games-strategy/uqm/uqm-0.6.2.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/uqm-0.6.2.ebuild,v 1.13 2011/06/24 11:31:11 tupone Exp $
-
-EAPI=2
-inherit eutils multilib games
-
-DESCRIPTION="The Ur-Quan Masters: Port of Star Control 2"
-HOMEPAGE="http://sc2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sc2/${P}-source.tgz
- mirror://sourceforge/sc2/${PN}-0.6.0-content.uqm
- music? ( mirror://sourceforge/sc2/${PN}-0.6.0-3domusic.uqm )
- voice? ( mirror://sourceforge/sc2/${PN}-0.6.0-voice.uqm )
- remix? ( mirror://sourceforge/sc2/${PN}-remix-pack1.zip \
- mirror://sourceforge/sc2/${PN}-remix-pack2.zip \
- mirror://sourceforge/sc2/${PN}-remix-pack3.zip )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="music opengl remix voice"
-
-RDEPEND="media-libs/libvorbis
- virtual/jpeg
- >=media-libs/libpng-1.4
- media-libs/libsdl
- media-libs/sdl-image
- media-libs/libogg
- media-libs/libvorbis
- media-libs/libmikmod"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${P}-source.tgz
-}
-
-src_prepare() {
- local myopengl
-
- # Because the new 0.6.* source archives have
- # everything in a subdir called "sc2". This,
- # I have found, is the simplest way to get
- # around that problem. (That doesn't change
- # the fact that the rest of this ebuild is
- # very nasty. I was not able to clean it up.)
- mv ./sc2/* ./
-
- use opengl \
- && myopengl=opengl \
- || myopengl=pure
-
- cat <<-EOF > config.state
- CHOICE_debug_VALUE='nodebug'
- CHOICE_graphics_VALUE='${myopengl}'
- CHOICE_sound_VALUE='mixsdl'
- CHOICE_accel_VALUE='plainc'
- INPUT_install_prefix_VALUE='${GAMES_PREFIX}'
- INPUT_install_bindir_VALUE='\$prefix/bin'
- INPUT_install_libdir_VALUE='\$prefix/lib'
- INPUT_install_sharedir_VALUE='${GAMES_DATADIR}/'
- EOF
-
- # Take out the read so we can be non-interactive.
- sed -i \
- -e '/read CHOICE/d' build/unix/menu_functions \
- || die "sed menu_functions failed"
-
- # support the user's CFLAGS.
- sed -i \
- -e "s/-O3/${CFLAGS}/" build/unix/build.config \
- || die "sed build.config failed"
-
- sed -i \
- -e "s:@INSTALL_LIBDIR@:$(games_get_libdir)/:g" build/unix/uqm-wrapper.in \
- || die "sed uqm-wrapper.in failed"
-}
-
-src_compile() {
- ./build.sh uqm || die "build failed"
-}
-
-src_install() {
- # Using the included install scripts seems quite painful.
- # This manual install is totally fragile but maybe they'll
- # use a sane build system for the next release.
- newgamesbin uqm-wrapper uqm || die "newgamesbin failed"
- exeinto "$(games_get_libdir)"/${PN}
- doexe uqm || die "doexe failed"
-
- insinto "${GAMES_DATADIR}"/${PN}/content/packages
- doins "${DISTDIR}"/${PN}-0.6.0-content.uqm || die "doins failed"
- echo ${P} > "${D}${GAMES_DATADIR}"/${PN}/content/version \
- || die "creating version file failed"
-
- insinto "${GAMES_DATADIR}"/${PN}/content/packages
- if use music; then
- doins "${DISTDIR}"/${PN}-0.6.0-3domusic.uqm || die "doins failed"
- fi
-
- if use voice; then
- doins "${DISTDIR}"/${PN}-0.6.0-voice.uqm || die "doins failed"
- fi
-
- if use remix; then
- insinto "${GAMES_DATADIR}"/${PN}/content/packages/addons/uqmremix
- doins "${DISTDIR}"/${PN}-remix-pack{1,2,3}.zip || die "doins failed"
- fi
-
- dodoc AUTHORS ChangeLog Contributing README WhatsNew doc/users/manual.txt
- docinto devel
- dodoc doc/devel/[!n]*
- docinto devel/netplay
- dodoc doc/devel/netplay/*
- make_desktop_entry uqm "The Ur-Quan Masters"
- prepgamesdirs
-
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if use remix ; then
- echo
- elog "To hear all the remixed music made by the The Ur-Quan Masters"
- elog "project's Precursors Team instead of the original ones,"
- elog "start the game with:"
- elog " --addon uqmremix"
- echo
- fi
-}