summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-03-11 12:14:23 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-03-11 12:14:23 +0000
commit9c8b2b0375d3f540373d2f928389e34db2c9e867 (patch)
tree87dc3a68c3d5c6d72895455ec91e3106cb5cbf81 /games-strategy/ufo-ai
parentFixes gcc 3.3 compilation errors. (Manifest recommit) (diff)
downloadgentoo-2-9c8b2b0375d3f540373d2f928389e34db2c9e867.tar.gz
gentoo-2-9c8b2b0375d3f540373d2f928389e34db2c9e867.tar.bz2
gentoo-2-9c8b2b0375d3f540373d2f928389e34db2c9e867.zip
Fixing up ebuild to use complete paths and ${S}. Closing bug #44327.
Diffstat (limited to 'games-strategy/ufo-ai')
-rw-r--r--games-strategy/ufo-ai/ChangeLog6
-rw-r--r--games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild24
2 files changed, 19 insertions, 11 deletions
diff --git a/games-strategy/ufo-ai/ChangeLog b/games-strategy/ufo-ai/ChangeLog
index 64cb66cb9eaf..0293d648c77c 100644
--- a/games-strategy/ufo-ai/ChangeLog
+++ b/games-strategy/ufo-ai/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/ufo-ai
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.1 2004/03/11 02:26:22 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.2 2004/03/11 12:14:23 wolf31o2 Exp $
+
+ 11 Mar 2004; Chris Gianelloni <wolf31o2@gentoo.org>
+ ufo-ai-0.10.040218.ebuild:
+ Fixing up ebuild to use complete paths and . Closing bug #44327.
*ufo-ai-0.10.040218 (10 Mar 2004)
diff --git a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
index afca1a2002e5..782e8f25c736 100644
--- a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
+++ b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.1 2004/03/11 02:26:22 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.2 2004/03/11 12:14:23 wolf31o2 Exp $
inherit games
@@ -21,28 +21,32 @@ DEPEND="virtual/glibc
media-libs/libogg"
src_unpack() {
- unpack ${A}
- cd source/linux
- epatch ${FILESDIR}/${PV}-Makefile.patch
+ unpack ${A} || die "unpack failed"
+ cd ${S}/source/linux || die "change dir"
+ epatch ${FILESDIR}/${PV}-Makefile.patch || die "patching"
}
src_compile() {
- cd source/linux
+ cd ${S}/source/linux || die "change dir"
make build_release \
OPTCFLAGS="${CFLAGS}" \
|| die "make failed"
- cd ../..
}
src_install() {
dodir ${GAMES_DATADIR}/${PN}
- cp -rf ufo/* ${D}${GAMES_DATADIR}/${PN}
- cd source/linux/releasei386-glibc
+ cp -rf ${S}/ufo/* ${D}${GAMES_DATADIR}/${PN} || die "copy data"
+ cd ${S}/source/linux/releasei386-glibc || die "change dir"
exeinto ${GAMES_DATADIR}/${PN}
- doexe ref_gl.so ref_glx.so ufo
+ doexe ${S}/source/linux/releasei386-glibc/{ref_gl.so,ref_glx.so,ufo} \
+ || die "doexe ufo"
exeinto ${GAMES_DATADIR}/${PN}/base
- doexe gamei386.so
+ doexe ${S}/source/linux/releasei386-glibc/gamei386.so \
+ || die "doexe gamei386.so"
games_make_wrapper ufo-ai ./ufo ${GAMES_DATADIR}/${PN}
prepgamesdirs
}
+pkg_postinst() {
+ games_pkg_postinst
+}