summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-12 07:36:45 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-12 07:36:45 +0000
commite3a9f495fec999b919d6daa7d69c6a58b3f154d6 (patch)
treeb98fc7e65c81de845cdce3e46b4b35d60d81fe4e /games-strategy/netherearth
parentx86 stable wrt bug #340213 (diff)
downloadgentoo-2-e3a9f495fec999b919d6daa7d69c6a58b3f154d6.tar.gz
gentoo-2-e3a9f495fec999b919d6daa7d69c6a58b3f154d6.tar.bz2
gentoo-2-e3a9f495fec999b919d6daa7d69c6a58b3f154d6.zip
Respect LDFLAGS. Bug #335718
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-strategy/netherearth')
-rw-r--r--games-strategy/netherearth/ChangeLog6
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-ldflags.patch8
-rw-r--r--games-strategy/netherearth/netherearth-0.52.ebuild5
3 files changed, 16 insertions, 3 deletions
diff --git a/games-strategy/netherearth/ChangeLog b/games-strategy/netherearth/ChangeLog
index dae3c954be77..da409328bdee 100644
--- a/games-strategy/netherearth/ChangeLog
+++ b/games-strategy/netherearth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/netherearth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/ChangeLog,v 1.7 2010/09/16 17:04:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/ChangeLog,v 1.8 2010/10/12 07:36:45 tupone Exp $
+
+ 12 Oct 2010; Tupone Alfredo <tupone@gentoo.org> netherearth-0.52.ebuild,
+ +files/netherearth-0.52-ldflags.patch:
+ Respect LDFLAGS. Bug #335718 by flameeyes@gentoo.org
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
netherearth-0.52.ebuild:
diff --git a/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch b/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
new file mode 100644
index 000000000000..6b7ed3a8989c
--- /dev/null
+++ b/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
@@ -0,0 +1,8 @@
+--- Makefile.old 2010-10-12 09:30:19.000000000 +0200
++++ Makefile 2010-10-12 09:30:38.000000000 +0200
+@@ -17,4 +17,4 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJECTS)
+- g++ $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
++ g++ $(LDFLAGS) $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
diff --git a/games-strategy/netherearth/netherearth-0.52.ebuild b/games-strategy/netherearth/netherearth-0.52.ebuild
index 33236fd7b0c2..2116e8f4ac8e 100644
--- a/games-strategy/netherearth/netherearth-0.52.ebuild
+++ b/games-strategy/netherearth/netherearth-0.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/netherearth-0.52.ebuild,v 1.7 2010/09/16 17:04:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/netherearth-0.52.ebuild,v 1.8 2010/10/12 07:36:45 tupone Exp $
inherit eutils games
@@ -38,7 +38,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-linux.patch
epatch "${FILESDIR}"/${P}-freeglut.patch \
- "${FILESDIR}"/${P}-glibc-212.patch
+ "${FILESDIR}"/${P}-glibc-212.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
# Modify dirs and some fopen() permissions
epatch "${FILESDIR}/${P}-gentoo-paths.patch"