summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-20 02:06:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-20 02:06:25 +0000
commite11cb7a2c49e6737f761533c461c117ce50ca516 (patch)
tree4760e1df61be37bb0657f81ff2def3750d91bafb /games-strategy/glest
parentBetter descriptions for apache mpm-* local USE flags (diff)
downloadgentoo-2-e11cb7a2c49e6737f761533c461c117ce50ca516.tar.gz
gentoo-2-e11cb7a2c49e6737f761533c461c117ce50ca516.tar.bz2
gentoo-2-e11cb7a2c49e6737f761533c461c117ce50ca516.zip
Version bump #98617 by Dennis Schridde.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-strategy/glest')
-rw-r--r--games-strategy/glest/ChangeLog9
-rw-r--r--games-strategy/glest/files/digest-glest-1.1.05
-rw-r--r--games-strategy/glest/files/glest7
-rw-r--r--games-strategy/glest/files/glest-1.1.0-fake-checkGlCaps.patch10
-rw-r--r--games-strategy/glest/glest-1.1.0.ebuild75
5 files changed, 102 insertions, 4 deletions
diff --git a/games-strategy/glest/ChangeLog b/games-strategy/glest/ChangeLog
index 7e860d14f84d..6cbe81e4a9f3 100644
--- a/games-strategy/glest/ChangeLog
+++ b/games-strategy/glest/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/glest
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.3 2005/06/13 00:10:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.4 2005/08/20 02:06:24 vapier Exp $
+
+*glest-1.1.0 (20 Aug 2005)
+
+ 20 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/glest-1.1.0-fake-checkGlCaps.patch, files/glest,
+ +glest-1.1.0.ebuild:
+ Version bump #98617 by Dennis Schridde.
13 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+files/glest-1.0.10_p7-fake-checkGlCaps.patch, glest-1.0.10_p7.ebuild:
diff --git a/games-strategy/glest/files/digest-glest-1.1.0 b/games-strategy/glest/files/digest-glest-1.1.0
new file mode 100644
index 000000000000..e40751587cda
--- /dev/null
+++ b/games-strategy/glest/files/digest-glest-1.1.0
@@ -0,0 +1,5 @@
+MD5 f549d496789d4a54166a7c386232069e glest-source-1.1.0.tar.bz2 327080
+MD5 bbf40de52ad412b1e36fc3bc1f6822fc glest_data_v1.1.0.zip 47949129
+MD5 4bfe6d6fa50c30f881376b85b53f1a0b german.lng 3573
+MD5 902eaa96b6ee22f50b342367ccb63b19 russian.lng 3519
+MD5 cbd43da7628d87d37d505b620ba2a99e dansk.lng 3423
diff --git a/games-strategy/glest/files/glest b/games-strategy/glest/files/glest
index de0c3985cf0c..f4e7ffe48b72 100644
--- a/games-strategy/glest/files/glest
+++ b/games-strategy/glest/files/glest
@@ -6,9 +6,10 @@ GLESTDIR="$GAMESDIR/glest"
if [ ! -d ~/.glest ]; then
mkdir ~/.glest
fi
-for d in data Tech map tileset lib/glest ; do
- if [ ! -L ~/.glest/${d} ] ; then
- ln -s "${GLESTDIR}"/${d} ~/.glest/${d##*/}
+for d in "${GLESTDIR}"/* lib/glest ; do
+ s=${d##*/}
+ if [ ! -L ~/.glest/${s} ] ; then
+ ln -s "${d}" ~/.glest/${s}
fi
done
if [ ! -e ~/.glest/glest.ini ] ; then
diff --git a/games-strategy/glest/files/glest-1.1.0-fake-checkGlCaps.patch b/games-strategy/glest/files/glest-1.1.0-fake-checkGlCaps.patch
new file mode 100644
index 000000000000..9092f3a8d053
--- /dev/null
+++ b/games-strategy/glest/files/glest-1.1.0-fake-checkGlCaps.patch
@@ -0,0 +1,10 @@
+--- glest_game/renderer.cpp
++++ glest_game/renderer.cpp
+@@ -2393,6 +2393,7 @@
+
+ void Renderer::checkGlCaps(){
+
++return;
+ //opengl 1.3
+ if(!isGlVersionSupported(1, 3, 0)){
+ throw runtime_error("Your system doesn't support OpenGL version 1.3\nYou may solve this problem by installing your latest video card drivers");
diff --git a/games-strategy/glest/glest-1.1.0.ebuild b/games-strategy/glest/glest-1.1.0.ebuild
new file mode 100644
index 000000000000..54cc05bb0548
--- /dev/null
+++ b/games-strategy/glest/glest-1.1.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-1.1.0.ebuild,v 1.1 2005/08/20 02:06:24 vapier Exp $
+
+inherit eutils games
+
+DATAVERSION="${PV/_p?/}"
+SOURCEVERSION="${PV/_p/-r}"
+DESCRIPTION="Cross-platform 3D realtime strategy game"
+HOMEPAGE="http://www.glest.org/"
+SRC_URI="mirror://sourceforge/glest/glest-source-${SOURCEVERSION}.tar.bz2
+ mirror://sourceforge/glest/glest_data_v${DATAVERSION}.zip
+ linguas_de? ( http://www.stud.uni-karlsruhe.de/~uxsm/german.lng )
+ linguas_ru? ( http://www.stud.uni-karlsruhe.de/~uxsm/russian.lng )
+ linguas_dk? ( http://www.stud.uni-karlsruhe.de/~uxsm/dansk.lng )"
+
+LICENSE="GPL-2 glest-data"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2.5
+ media-libs/libogg
+ media-libs/libvorbis
+ >=media-libs/openal-20040303
+ dev-libs/xerces-c
+ virtual/opengl
+ virtual/x11"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=sys-devel/gcc-3.2
+ >=dev-util/jam-2.5"
+
+S=${WORKDIR}/${PN}-${DATAVERSION}
+
+src_unpack() {
+ unpack glest-source-${SOURCEVERSION}.tar.bz2 glest_data_v${DATAVERSION}.zip
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fake-checkGlCaps.patch
+ # sometimes they package configure, sometimes they dont
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_compile() {
+ egamesconf \
+ --with-vorbis=/usr \
+ --with-ogg=/usr \
+ || die
+ jam || die "jam failed"
+}
+
+src_install() {
+ dogamesbin "${FILESDIR}"/glest || die "couldn't install launcher"
+ dosed "s:GENTOO_DATADIR:${GAMES_DATADIR}:" "${GAMES_BINDIR}"/glest
+
+ exeinto "${GAMES_DATADIR}"/${PN}/lib
+ doexe glest || die "doexe failed"
+
+ cd "${WORKDIR}"/glest_game
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r techs data maps tilesets || die "data copy failed"
+ insinto "${GAMES_DATADIR}"/${PN}/config
+ doins glest.ini || die "config copy failed"
+ dodoc readme.txt
+
+ use linguas_de && cp "${DISTDIR}"/german.lng "${D}/${GAMES_DATADIR}"/${PN}/data/lang/
+ use linguas_ru && cp "${DISTDIR}"/russian.lng "${D}/${GAMES_DATADIR}"/${PN}/data/lang/
+ use linguas_dk && cp "${DISTDIR}"/dansk.lng "${D}/${GAMES_DATADIR}"/${PN}/data/lang/
+
+ make_desktop_entry glest Glest
+
+ prepgamesdirs
+}