summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-04-13 20:16:18 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-04-13 20:16:18 +0000
commit0daebf254a6cc415f76b670022fcc86202482c95 (patch)
treee1aa2b7eec4cbbb2b91d5bce0e901a90267a34dd /games-strategy/freesynd
parentVersion bump. Removed old (diff)
downloadgentoo-2-0daebf254a6cc415f76b670022fcc86202482c95.tar.gz
gentoo-2-0daebf254a6cc415f76b670022fcc86202482c95.tar.bz2
gentoo-2-0daebf254a6cc415f76b670022fcc86202482c95.zip
version bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-strategy/freesynd')
-rw-r--r--games-strategy/freesynd/ChangeLog8
-rw-r--r--games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch28
-rw-r--r--games-strategy/freesynd/freesynd-0.7.1.ebuild80
3 files changed, 115 insertions, 1 deletions
diff --git a/games-strategy/freesynd/ChangeLog b/games-strategy/freesynd/ChangeLog
index 827014c577d2..1fcf0195d813 100644
--- a/games-strategy/freesynd/ChangeLog
+++ b/games-strategy/freesynd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freesynd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freesynd/ChangeLog,v 1.1 2013/03/10 02:45:28 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freesynd/ChangeLog,v 1.2 2013/04/13 20:16:17 hasufell Exp $
+
+*freesynd-0.7.1 (13 Apr 2013)
+
+ 13 Apr 2013; Julian Ospald <hasufell@gentoo.org> +freesynd-0.7.1.ebuild,
+ +files/freesynd-0.7.1-cmake.patch:
+ version bump
*freesynd-0.7 (10 Mar 2013)
diff --git a/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch b/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch
new file mode 100644
index 000000000000..817cd39dcb4f
--- /dev/null
+++ b/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch
@@ -0,0 +1,28 @@
+--- freesynd-0.7.1/CMakeLists.txt
++++ freesynd-0.7.1/CMakeLists.txt
+@@ -34,6 +34,13 @@
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_C_FLAGS}")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${EXTRA_CXX_FLAGS}")
+
++option(BUILD_DEV_TOOLS "Build development tools")
++option(WITH_DEBUG "Enable debug definitions")
++
++if(WITH_DEBUG)
++ add_definitions (-D_DEBUG)
++endif()
++
+ # Set standard definitions for all platforms.
+ add_definitions (-DSYSTEM_SDL)
+ add_definitions (-DPREFIX=\"${CMAKE_INSTALL_PREFIX}\")
+@@ -59,10 +66,7 @@
+ message (FATAL_ERROR "Unable to locate PNG")
+ endif ()
+
+-if (NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE STREQUAL "debug")
+- set (BUILD_DEV_TOOLS TRUE)
+-else ()
+- set (BUILD_DEV_TOOLS FALSE)
++if (CMAKE_BUILD_TYPE AND NOT CMAKE_BUILD_TYPE STREQUAL "debug")
+ # We only define an install target if we're doing a release build.
+ # Furthermore, on Mac, the data folder is a part of the app bundle.
+ if (NOT APPLE)
diff --git a/games-strategy/freesynd/freesynd-0.7.1.ebuild b/games-strategy/freesynd/freesynd-0.7.1.ebuild
new file mode 100644
index 000000000000..07b97bac72c5
--- /dev/null
+++ b/games-strategy/freesynd/freesynd-0.7.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freesynd/freesynd-0.7.1.ebuild,v 1.1 2013/04/13 20:16:17 hasufell Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils gnome2-utils games
+
+DESCRIPTION="A cross-platform reimplementation of engine for the classic Bullfrog game, Syndicate"
+HOMEPAGE="http://freesynd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug devtools"
+
+RDEPEND="media-libs/libogg
+ media-libs/libpng:0
+ media-libs/libsdl[X,audio,video]
+ media-libs/libvorbis
+ media-libs/sdl-mixer[mp3,vorbis]
+ media-libs/sdl-image[png]"
+DEPEND="${RDEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cmake.patch
+
+ sed \
+ -e "s:#freesynd_data_dir = /usr/share/freesynd/data:freesynd_data_dir = ${GAMES_DATADIR}/${PN}/data:" \
+ -i ${PN}.ini || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with debug DEBUG)
+ $(cmake-utils_use_build devtools DEV_TOOLS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dogamesbin src/${PN}
+ use devtools && newgamesbin src/dump ${PN}-dump
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data
+ newicon -s 128 icon/sword.png ${PN}.png
+ make_desktop_entry ${PN}
+ dodoc NEWS README INSTALL AUTHORS
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "You have to set \"data_dir = /my/path/to/synd-data\""
+ elog "in \"~/.${PN}/${PN}.ini\"."
+
+ if use debug ; then
+ ewarn "Debug build is not meant for regular playing,"
+ ewarn "game speed is higher."
+ fi
+
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}