summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-04 20:21:02 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-04 20:21:02 +0000
commit2d0ad1c44eb939ff49746da687ee450cca2457c6 (patch)
tree05fd1ce004776166ef313fc8d9e0914b1b780fc9 /games-sports
parentVersion bump. (diff)
downloadgentoo-2-2d0ad1c44eb939ff49746da687ee450cca2457c6.tar.gz
gentoo-2-2d0ad1c44eb939ff49746da687ee450cca2457c6.tar.bz2
gentoo-2-2d0ad1c44eb939ff49746da687ee450cca2457c6.zip
Version bump to latest. Fixes bug #354371.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/ChangeLog8
-rw-r--r--games-sports/xmoto/files/0.5.7-libpng.patch12
-rw-r--r--games-sports/xmoto/xmoto-0.5.7.ebuild91
3 files changed, 110 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 42a3b96ff787..9db5d8c10f4b 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.55 2011/03/04 01:35:18 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.56 2011/05/04 20:21:01 scarabeus Exp $
+
+*xmoto-0.5.7 (04 May 2011)
+
+ 04 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.5.7-libpng.patch, +xmoto-0.5.7.ebuild:
+ Version bump to latest. Fixes bug #354371.
04 Mar 2011; Brent Baude <ranger@gentoo.org> xmoto-0.5.4.ebuild:
stable ppc, bug 352162
diff --git a/games-sports/xmoto/files/0.5.7-libpng.patch b/games-sports/xmoto/files/0.5.7-libpng.patch
new file mode 100644
index 000000000000..208046c38221
--- /dev/null
+++ b/games-sports/xmoto/files/0.5.7-libpng.patch
@@ -0,0 +1,12 @@
+diff --git a/xmoto-0.5.7.old/src/image/tim_png.cpp b/xmoto-0.5.7/src/image/tim_png.cpp
+index 75fd545..e4073dc 100644
+--- a/xmoto-0.5.7.old/src/image/tim_png.cpp
++++ b/xmoto-0.5.7/src/image/tim_png.cpp
+@@ -26,6 +26,7 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ #include <string.h>
+ #include "tim.h"
+ #include "png.h"
++#include "zlib.h"
+
+ /*==============================================================================
+ Types
diff --git a/games-sports/xmoto/xmoto-0.5.7.ebuild b/games-sports/xmoto/xmoto-0.5.7.ebuild
new file mode 100644
index 000000000000..5fd68efbae56
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.5.7.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.5.7.ebuild,v 1.1 2011/05/04 20:21:01 scarabeus Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+LVL_PV="0.7.0" #they unfortunately don't release both at the same time, why ~ as separator :(
+LVL="inksmoto-${LVL_PV}"
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/${PN}/${PV}/${P}-src.tar.gz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL_PV}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="editor nls"
+
+RDEPEND="
+ dev-libs/libxdg-basedir
+ dev-db/sqlite:3
+ dev-games/ode
+ dev-lang/lua[deprecated]
+ virtual/jpeg
+ media-libs/libpng
+ media-libs/libsdl[joystick]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ net-misc/curl
+ app-arch/bzip2
+ virtual/opengl
+ virtual/glu
+ media-fonts/dejavu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ editor? ( media-gfx/inkscape )"
+
+src_prepare() {
+ use editor && rm -vf "${WORKDIR}"/extensions/{bezmisc,inkex}.py
+ sed -i \
+ -e '/^gettextsrcdir/s:=.*:= @localedir@/gettext/po:' \
+ po/Makefile.in.in || die
+
+ epatch "${FILESDIR}"/${PV}-libpng.patch
+}
+
+src_configure() {
+ # bug #289792
+ filter-flags -DdDOUBLE
+ has_version 'dev-games/ode[double-precision]' && append-flags -DdDOUBLE
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-threads=posix \
+ $(use_enable nls) \
+ --localedir=/usr/share/locale \
+ --with-localesdir=/usr/share/locale \
+ --with-renderer-sdlGfx=0 \
+ --with-renderer-openGl=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO NEWS ChangeLog || die
+
+ rm -f "${D}${GAMES_DATADIR}/${PN}"/Textures/Fonts/DejaVuSans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}/${PN}"/Textures/Fonts/
+ doicon extra/xmoto.xpm
+ make_desktop_entry ${PN} Xmoto
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/
+ doins -r "${WORKDIR}"/extensions/ || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog " http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-${LVL_PV}"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}