summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-09 19:22:27 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-09 19:22:27 +0000
commit297d39ce97cec59b5242c176ae700184f1e9a406 (patch)
treee3e37db45d0782626737a72b18220279b167b761 /games-sports/toycars
parentMoved from dev-php5/jpgraph (diff)
downloadgentoo-2-297d39ce97cec59b5242c176ae700184f1e9a406.tar.gz
gentoo-2-297d39ce97cec59b5242c176ae700184f1e9a406.tar.bz2
gentoo-2-297d39ce97cec59b5242c176ae700184f1e9a406.zip
Fix build with gcc-4.6 Bug #362735
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'games-sports/toycars')
-rw-r--r--games-sports/toycars/ChangeLog6
-rw-r--r--games-sports/toycars/files/toycars-0.3.10-gcc46.patch10
-rw-r--r--games-sports/toycars/toycars-0.3.10.ebuild6
3 files changed, 19 insertions, 3 deletions
diff --git a/games-sports/toycars/ChangeLog b/games-sports/toycars/ChangeLog
index c47165a61f49..eb89e4ef679f 100644
--- a/games-sports/toycars/ChangeLog
+++ b/games-sports/toycars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/toycars
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.18 2011/03/20 20:16:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.19 2011/04/09 19:22:27 tupone Exp $
+
+ 09 Apr 2011; Alfredo Tupone <tupone@gentoo.org> toycars-0.3.10.ebuild,
+ +files/toycars-0.3.10-gcc46.patch:
+ Fix build with gcc-4.6 Bug #362735 by Diego Elio Pettenò
20 Mar 2011; Justin Lecher <jlec@gentoo.org> toycars-0.3.10.ebuild:
x11-libs/fltk SLOTMOVE 1.1 -> 1, corrected ebuild accordingly
diff --git a/games-sports/toycars/files/toycars-0.3.10-gcc46.patch b/games-sports/toycars/files/toycars-0.3.10-gcc46.patch
new file mode 100644
index 000000000000..127b75920322
--- /dev/null
+++ b/games-sports/toycars/files/toycars-0.3.10-gcc46.patch
@@ -0,0 +1,10 @@
+--- toycars/src/MyFisix/Convex.h.old 2011-04-09 21:17:43.000000000 +0200
++++ toycars/src/MyFisix/Convex.h 2011-04-09 21:18:22.000000000 +0200
+@@ -21,6 +21,7 @@
+ #include "config.h"
+ #endif
+
++#include <cstddef>
+ #include <list>
+ using namespace std;
+
diff --git a/games-sports/toycars/toycars-0.3.10.ebuild b/games-sports/toycars/toycars-0.3.10.ebuild
index e16758f56325..1eab29539aa7 100644
--- a/games-sports/toycars/toycars-0.3.10.ebuild
+++ b/games-sports/toycars/toycars-0.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/toycars-0.3.10.ebuild,v 1.7 2011/03/20 20:16:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/toycars-0.3.10.ebuild,v 1.8 2011/04/09 19:22:27 tupone Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -20,11 +20,13 @@ DEPEND="media-libs/libsdl[audio,video,joystick]
>=media-libs/fmod-4.25.07-r1:1
virtual/glu
virtual/opengl"
+RDEPEND="${DEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-glibc-2.10.patch \
- "${FILESDIR}"/${P}-gcc45.patch
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
mv data/tracks/Corner/{c,C}orner.map
}