summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-07 15:58:47 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-07 15:58:47 +0000
commitbb26410e301bc469db8b77a54043eb40d46de016 (patch)
tree3bcf58f050c5ad3afce0b618ac7760a99de28934 /games-simulation
parentinitial ebuild (diff)
downloadgentoo-2-bb26410e301bc469db8b77a54043eb40d46de016.tar.gz
gentoo-2-bb26410e301bc469db8b77a54043eb40d46de016.tar.bz2
gentoo-2-bb26410e301bc469db8b77a54043eb40d46de016.zip
initial ebuild
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/bcsdemo/ChangeLog8
-rw-r--r--games-simulation/bcsdemo/bcsdemo-1.3.ebuild44
-rw-r--r--games-simulation/bcsdemo/files/digest-bcsdemo-1.31
-rw-r--r--games-simulation/bcsdemo/metadata.xml30
4 files changed, 83 insertions, 0 deletions
diff --git a/games-simulation/bcsdemo/ChangeLog b/games-simulation/bcsdemo/ChangeLog
new file mode 100644
index 000000000000..63031d72fc84
--- /dev/null
+++ b/games-simulation/bcsdemo/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-simulation/bcsdemo
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcsdemo/ChangeLog,v 1.1 2003/10/07 15:58:47 vapier Exp $
+
+*bcsdemo-1.3 (07 Oct 2003)
+
+ 07 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-simulation/bcsdemo/bcsdemo-1.3.ebuild b/games-simulation/bcsdemo/bcsdemo-1.3.ebuild
new file mode 100644
index 000000000000..45a1bc5335de
--- /dev/null
+++ b/games-simulation/bcsdemo/bcsdemo-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcsdemo/bcsdemo-1.3.ebuild,v 1.1 2003/10/07 15:58:47 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="design and build bridges and then stress test them with trains"
+HOMEPAGE="http://garagegames.com/pg/product/view.php?id=17"
+SRC_URI="ftp://ggdev-1.homelan.com/bcs/bcsdemo_v${PV/./_}.sh.bin"
+
+LICENSE="BCS"
+SLOT="0"
+KEYWORDS="-* x86"
+
+DEPEND=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ check_license
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir} ${GAMES_BINDIR}
+
+ tar -zxf bcsdemo.tar.gz -C ${D}/${dir} || die "extracting bcsdemo.tar.gz"
+
+ exeinto ${dir}
+ doexe bin/Linux/x86/rungame.sh
+ dosym ${dir}/rungame.sh ${GAMES_BINDIR}/bcsdemo
+
+ insinto ${dir}
+ doins *.cfg
+
+ dodoc readme*
+
+ prepgamesdirs
+}
diff --git a/games-simulation/bcsdemo/files/digest-bcsdemo-1.3 b/games-simulation/bcsdemo/files/digest-bcsdemo-1.3
new file mode 100644
index 000000000000..3a1b748531cd
--- /dev/null
+++ b/games-simulation/bcsdemo/files/digest-bcsdemo-1.3
@@ -0,0 +1 @@
+MD5 ed370f8925f573429ffd810703149ca8 bcsdemo_v1_3.sh.bin 5965217
diff --git a/games-simulation/bcsdemo/metadata.xml b/games-simulation/bcsdemo/metadata.xml
new file mode 100644
index 000000000000..73ab80a02c79
--- /dev/null
+++ b/games-simulation/bcsdemo/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+Building a bridge that doesn't break is what its all about, although watching
+your bridge creation break and plunge a train into the watery depths below can be
+half the fun. In the Bridge Construction Set you design and build bridges and
+then stress test them to see how your creations hold up under pressure. If when
+test vehicles pass over your bridge they make it safely across you know you´ve
+succeeded. If they plummet into the river you know you need to go back to the
+drawing board.
+
+The robust physics deployed in the Bridge Construction Set let you build a wide
+variety of bridges that can span the river. The 3D graphics allow you to view
+your bridge from any angle including a first person train view - its like being
+strapped to the front of the train when your bridge is first tested (if this
+happened in real life I think we might have engineers checking all their bridges
+in a simulator).
+
+The Bridge Construction Set includes many types of bridge building levels in
+varying degrees of difficulty from simple to complex with a tutorial secition to
+get you started. A Level Editor is also included so you can create your own
+levels and trade them with others.
+</longdescription>
+</pkgmetadata>