summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-08-29 13:47:06 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-08-29 13:47:06 +0000
commit8ac6b2ecdc4d6f265e07b1f24689397398b1486b (patch)
tree6501f95f5903722f8a6fc9d327952ae5d9169b7f /games-simulation
parentStable on Alpha, bug 145447. (diff)
downloadgentoo-2-8ac6b2ecdc4d6f265e07b1f24689397398b1486b.tar.gz
gentoo-2-8ac6b2ecdc4d6f265e07b1f24689397398b1486b.tar.bz2
gentoo-2-8ac6b2ecdc4d6f265e07b1f24689397398b1486b.zip
Fix for gcc-4.1, bug #145273
(Portage version: 2.1-r2)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/flightgear/ChangeLog7
-rw-r--r--games-simulation/flightgear/files/digest-flightgear-0.9.94
-rw-r--r--games-simulation/flightgear/files/flightgear-0.9.9-gcc41.patch44
-rw-r--r--games-simulation/flightgear/flightgear-0.9.9.ebuild9
4 files changed, 59 insertions, 5 deletions
diff --git a/games-simulation/flightgear/ChangeLog b/games-simulation/flightgear/ChangeLog
index 50aa0d915187..082fd3dc2f7c 100644
--- a/games-simulation/flightgear/ChangeLog
+++ b/games-simulation/flightgear/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/flightgear
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.23 2006/04/08 01:45:49 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.24 2006/08/29 13:47:06 tupone Exp $
+
+ 29 Aug 2006; <tupone@gentoo.org> +files/flightgear-0.9.9-gcc41.patch,
+ flightgear-0.9.9.ebuild:
+ Fixing build with gcc-4.1, bug #145273 by Paulo Jorge de Oliveira Cantante de
+ Matos
*flightgear-0.9.10 (08 Apr 2006)
diff --git a/games-simulation/flightgear/files/digest-flightgear-0.9.9 b/games-simulation/flightgear/files/digest-flightgear-0.9.9
index e143d8d23351..385d8c01b54a 100644
--- a/games-simulation/flightgear/files/digest-flightgear-0.9.9
+++ b/games-simulation/flightgear/files/digest-flightgear-0.9.9
@@ -1,2 +1,6 @@
MD5 c1bff0cc9eda34f2a31ec9cd4e5216e6 FlightGear-0.9.9.tar.gz 1771791
+RMD160 ccf95c96531c9a2ed3eae0ccd90816c0a1f72737 FlightGear-0.9.9.tar.gz 1771791
+SHA256 46597145e087d116e479bf9048c06a0c84107ebda62420d783104831e4775c6a FlightGear-0.9.9.tar.gz 1771791
MD5 c262f7022479c249c486a195d6755579 fgfs-base-0.9.9.tar.bz2 85943212
+RMD160 607f901c19251596705f61a7110431cf5c8d6193 fgfs-base-0.9.9.tar.bz2 85943212
+SHA256 5524223a0b7ef51c3cd565b441c5e858bb8f902f077c5512d44787a6e04fe5ad fgfs-base-0.9.9.tar.bz2 85943212
diff --git a/games-simulation/flightgear/files/flightgear-0.9.9-gcc41.patch b/games-simulation/flightgear/files/flightgear-0.9.9-gcc41.patch
new file mode 100644
index 000000000000..51bb4ebf5094
--- /dev/null
+++ b/games-simulation/flightgear/files/flightgear-0.9.9-gcc41.patch
@@ -0,0 +1,44 @@
+--- src/Environment/fgclouds.hxx.old 2006-08-29 13:30:28.000000000 +0200
++++ src/Environment/fgclouds.hxx 2006-08-29 13:30:43.000000000 +0200
+@@ -53,7 +53,7 @@
+
+ void update_metar_properties( FGMetar *m );
+
+- void FGClouds::update_env_config ();
++ void update_env_config ();
+
+ int update_event;
+ SGSoundSample *snd_lightning;
+--- src/Environment/environment_ctrl.cxx.old 2006-08-29 13:32:25.000000000 +0200
++++ src/Environment/environment_ctrl.cxx 2006-08-29 13:32:01.000000000 +0200
+@@ -702,6 +702,8 @@
+
+
+ #if defined(ENABLE_THREADS) && ENABLE_THREADS
++void
++metar_cleanup_handler( void* arg );
+ /**
+ *
+ */
+--- src/Traffic/SchedFlight.hxx.old 2006-08-29 14:10:18.000000000 +0200
++++ src/Traffic/SchedFlight.hxx 2006-08-29 14:10:50.000000000 +0200
+@@ -67,7 +67,7 @@
+ FGScheduledFlight();
+ FGScheduledFlight(const FGScheduledFlight &other);
+ // FGScheduledFlight(const string);
+- FGScheduledFlight::FGScheduledFlight(const string& cs,
++ FGScheduledFlight(const string& cs,
+ const string& fr,
+ const string& depPrt,
+ const string& arrPrt,
+--- src/Scenery/FGTileLoader.cxx.old 2006-08-29 14:16:12.000000000 +0200
++++ src/Scenery/FGTileLoader.cxx 2006-08-29 14:16:44.000000000 +0200
+@@ -156,6 +156,8 @@
+
+
+ #if defined(ENABLE_THREADS) && ENABLE_THREADS
++void
++cleanup_handler( void* arg );
+ /**
+ *
+ */
diff --git a/games-simulation/flightgear/flightgear-0.9.9.ebuild b/games-simulation/flightgear/flightgear-0.9.9.ebuild
index 448605c8bf65..c529473cc684 100644
--- a/games-simulation/flightgear/flightgear-0.9.9.ebuild
+++ b/games-simulation/flightgear/flightgear-0.9.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-0.9.9.ebuild,v 1.1 2005/12/07 16:30:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-0.9.9.ebuild,v 1.2 2006/08/29 13:47:06 tupone Exp $
-inherit flag-o-matic games
+inherit eutils flag-o-matic games
MY_PN=FlightGear
MY_P=${MY_PN}-${PV}
@@ -25,8 +25,9 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mv ../data ./data
+ epatch "${FILESDIR}/${P}"-gcc41.patch
}
src_compile() {