summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-10-01 23:56:44 +0000
committerLars Weiler <pylon@gentoo.org>2007-10-01 23:56:44 +0000
commit73e09f1891022197713bfbd953457c3e84efa739 (patch)
treee91a71491289d86e94f1107a07c82f175d8ba4c5 /games-simulation
parentold (diff)
downloadgentoo-2-73e09f1891022197713bfbd953457c3e84efa739.tar.gz
gentoo-2-73e09f1891022197713bfbd953457c3e84efa739.tar.bz2
gentoo-2-73e09f1891022197713bfbd953457c3e84efa739.zip
Fixed quoting issues and changed configure-call.
(Portage version: 2.1.3.11)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/openttd-0.5.3.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/games-simulation/openttd/openttd-0.5.3.ebuild b/games-simulation/openttd/openttd-0.5.3.ebuild
index b4b6067e514f..891b8b24efd4 100644
--- a/games-simulation/openttd/openttd-0.5.3.ebuild
+++ b/games-simulation/openttd/openttd-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.3.ebuild,v 1.1 2007/10/01 12:11:46 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.3.ebuild,v 1.2 2007/10/01 23:56:44 pylon Exp $
inherit eutils games
@@ -45,11 +45,11 @@ pkg_setup() {
src_unpack() {
unpack ${MY_P}-source.tar.bz2
if use scenarios ; then
- cd ${S}/scenario/
+ cd "${S}"/scenario/
unpack ${SCENARIOS_048}
unpack ${SCENARIOS_050}
fi
- cd ${S}
+ cd "${S}"
# Don't pre-strip binaries (bug #137822)
sed -i -e '/+= -s$/s/-s//' Makefile || die "sed failed"
# Don't install into prefixed DATA_DIR
@@ -61,11 +61,7 @@ src_unpack() {
src_compile() {
local myopts=""
use debug && myopts="${myopts} --debug"
- use static && myopts="${myopts} --with-static"
use dedicated && myopts="${myopts} --dedicated --without-sdl"
- use iconv && myopts="${myopts} --with-iconv"
- use png && myopts="${myopts} --with-png"
- use zlib && myopts="${myopts} --with-zlib"
if ! use dedicated; then
myopts="${myopts} --with-sdl --with-freetype --with-fontconfig"
if ! use timidity; then
@@ -76,6 +72,10 @@ src_compile() {
# configure is a hand-written sh-script, so econf will not work
./configure --os=UNIX \
--with-network \
+ $(use_with static) \
+ $(use_with iconv) \
+ $(use_with png) \
+ $(use_with zlib) \
${myopts} \
|| die "configure failed"
@@ -83,11 +83,11 @@ src_compile() {
MANUAL_CONFIG=1 \
INSTALL=1 \
USE_HOMEDIR=1 \
- DEST_DIR=${D} \
+ DEST_DIR="${D}" \
PERSONAL_DIR=.openttd \
- PREFIX=${GAMES_PREFIX} \
- DATA_DIR=${GAMES_DATADIR}/${PN} \
- CUSTOM_LANG_DIR=${GAMES_DATADIR}/${PN}/lang \
+ PREFIX="${GAMES_PREFIX}" \
+ DATA_DIR="${GAMES_DATADIR}"/${PN} \
+ CUSTOM_LANG_DIR="${GAMES_DATADIR}"/${PN}/lang \
|| die "emake failed"
}