summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-03-07 21:35:02 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-03-07 21:35:02 +0000
commit5c60ca3ea532e2ee28a3a5ebc703af88c773e448 (patch)
treeaf92716cdbb09a6c0caf2733b135c9917ccb3cbf /games-simulation
parentAdd arm64 love. (diff)
downloadgentoo-2-5c60ca3ea532e2ee28a3a5ebc703af88c773e448.tar.gz
gentoo-2-5c60ca3ea532e2ee28a3a5ebc703af88c773e448.tar.bz2
gentoo-2-5c60ca3ea532e2ee28a3a5ebc703af88c773e448.zip
EAPI 5
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/cannonsmash/ChangeLog7
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild14
2 files changed, 11 insertions, 10 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index f6c7b5891638..a02e9acdd0a6 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/cannonsmash
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.23 2014/05/15 16:59:30 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.24 2015/03/07 21:35:02 tupone Exp $
+
+ 07 Mar 2015; Tupone Alfredo <tupone@gentoo.org> cannonsmash-0.6.6.ebuild:
+ EAPI 5
15 May 2014; Ulrich Müller <ulm@gentoo.org> cannonsmash-0.6.6.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index 4ad310e719a2..b55f65549b53 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.19 2014/05/15 16:59:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.20 2015/03/07 21:35:02 tupone Exp $
-EAPI=2
+EAPI=5
inherit eutils games
MY_OGG=danslatristesse2-48.ogg
@@ -54,18 +54,16 @@ src_configure() {
src_compile() {
emake \
- localedir="/usr/share" \
- || die "emake failed"
+ localedir="/usr/share"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
if use vorbis ; then
insinto "${GAMES_DATADIR}"/csmash
- doins "${DISTDIR}"/${MY_OGG} || die "doins failed"
+ doins "${DISTDIR}"/${MY_OGG}
fi
newicon win32/orange.ico ${PN}.ico
make_desktop_entry csmash "Cannon Smash" /usr/share/pixmaps/${PN}.ico
- dodoc AUTHORS CREDITS README*
prepgamesdirs
}