summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-10-17 17:34:40 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-10-17 17:34:40 +0000
commit2b2e91749c2fe3fe5166cb5cedf21e91eff15cf1 (patch)
tree6867746b846f29c9f73e83d03fc6d5a308e4037e /games-simulation
parentVersion cleanup and [R]DEPEND moved into vim.eclass (diff)
downloadgentoo-2-2b2e91749c2fe3fe5166cb5cedf21e91eff15cf1.tar.gz
gentoo-2-2b2e91749c2fe3fe5166cb5cedf21e91eff15cf1.tar.bz2
gentoo-2-2b2e91749c2fe3fe5166cb5cedf21e91eff15cf1.zip
Fix typo on src_configure. Bug #258405
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/fgrun/ChangeLog5
-rw-r--r--games-simulation/fgrun/fgrun-1.0.0.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/games-simulation/fgrun/ChangeLog b/games-simulation/fgrun/ChangeLog
index 47250bff4614..239b0076962e 100644
--- a/games-simulation/fgrun/ChangeLog
+++ b/games-simulation/fgrun/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/fgrun
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.6 2009/01/13 02:09:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.7 2009/10/17 17:34:40 tupone Exp $
+
+ 17 Oct 2009; Tupone Alfredo <tupone@gentoo.org> fgrun-1.0.0.ebuild:
+ Fix typo on src_configure. Bug #258405 by Steven Parker
13 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> fgrun-1.0.0.ebuild:
EAPI=2; add use-based dep
diff --git a/games-simulation/fgrun/fgrun-1.0.0.ebuild b/games-simulation/fgrun/fgrun-1.0.0.ebuild
index ee5b691ccefd..13a626c6c352 100644
--- a/games-simulation/fgrun/fgrun-1.0.0.ebuild
+++ b/games-simulation/fgrun/fgrun-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.0.0.ebuild,v 1.4 2009/01/13 02:09:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.0.0.ebuild,v 1.5 2009/10/17 17:34:40 tupone Exp $
EAPI=2
inherit autotools eutils multilib games
@@ -14,18 +14,19 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-games/simgear
+RDEPEND="dev-games/simgear
x11-libs/fltk:1.1[opengl]
games-simulation/flightgear
x11-libs/libXi
x11-libs/libXmu"
+DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}"-{fltk,gcc43}.patch
AT_M4DIR=. eautoreconf
}
-src_prepare() {
+src_configure() {
egamesconf \
--with-plib-libraries=/usr/$(get_libdir) \
--with-plib-includes=/usr/include \