summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-13 02:06:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-13 02:06:58 +0000
commit3a4d62b8c03883c4f64f526922fd0d2e7e153c5b (patch)
treed6f3825b961aa2f8d826dc0f050679a511fb86dd /games-simulation/cannonsmash
parentold (diff)
downloadgentoo-2-3a4d62b8c03883c4f64f526922fd0d2e7e153c5b.tar.gz
gentoo-2-3a4d62b8c03883c4f64f526922fd0d2e7e153c5b.tar.bz2
gentoo-2-3a4d62b8c03883c4f64f526922fd0d2e7e153c5b.zip
Add x-include fix by Jason Bucata and amd64 fix by Bernard Cafarelli #84187.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'games-simulation/cannonsmash')
-rw-r--r--games-simulation/cannonsmash/ChangeLog9
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild21
-rw-r--r--games-simulation/cannonsmash/files/cannonsmash-0.6.6-sizeof-cast.patch11
-rw-r--r--games-simulation/cannonsmash/files/cannonsmash-0.6.6-x-inc.patch18
4 files changed, 46 insertions, 13 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index df00ac19434a..f1cabbc0b20a 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/cannonsmash
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.10 2004/12/28 23:35:13 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.11 2005/05/13 02:06:58 vapier Exp $
+
+ 13 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/cannonsmash-0.6.6-sizeof-cast.patch,
+ +files/cannonsmash-0.6.6-x-inc.patch, cannonsmash-0.6.6.ebuild:
+ Add x-include fix by Jason Bucata and amd64 fix by Bernard Cafarelli #84187.
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index 404f4ae4ffc3..643ac5162c80 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.6 2004/12/16 15:55:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.7 2005/05/13 02:06:58 vapier Exp $
inherit games
@@ -12,26 +12,25 @@ SRC_URI="mirror://sourceforge/cannonsmash/csmash-${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="amd64 ppc x86"
IUSE="oggvorbis nls"
-RDEPEND="virtual/libc
- virtual/x11
+DEPEND="virtual/x11
virtual/opengl
>=media-libs/libsdl-1.2.4
>=media-libs/sdl-mixer-1.2.3
>=media-libs/sdl-image-1.2.2
=x11-libs/gtk+-1.2*"
-DEPEND="${RDEPEND}
- oggvorbis? ( >=sys-apps/sed-4 )"
-S="${WORKDIR}/csmash-${PV}"
+S=${WORKDIR}/csmash-${PV}
src_unpack() {
unpack csmash-${PV}.tar.gz
cd "${S}"
+ epatch "${FILESDIR}"/${P}-x-inc.patch
+ epatch "${FILESDIR}"/${P}-sizeof-cast.patch
if use oggvorbis ; then
- cp "${DISTDIR}/${MY_OGG}" "${S}/" || die "cp failed"
+ cp "${DISTDIR}"/${MY_OGG} "${S}"/ || die "cp failed"
sed -i \
-e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
|| die "setting ogg loc"
@@ -51,8 +50,8 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
if use oggvorbis ; then
- insinto "${GAMES_DATADIR}/csmash"
- doins "${MY_OGG}"
+ insinto "${GAMES_DATADIR}"/csmash
+ doins ${MY_OGG}
fi
dodoc AUTHORS CREDITS README*
prepgamesdirs
diff --git a/games-simulation/cannonsmash/files/cannonsmash-0.6.6-sizeof-cast.patch b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-sizeof-cast.patch
new file mode 100644
index 000000000000..9237f95978ef
--- /dev/null
+++ b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-sizeof-cast.patch
@@ -0,0 +1,11 @@
+Don't typecast otherwise C++ will fail to match on some arches.
+
+http://bugs.gentoo.org/84187
+
+--- loadparts.cpp
++++ loadparts.cpp
+@@ -247,3 +247,3 @@
+ // concat next line(s)
+- int bufsize = clamp(0U, sizeof(line)-l, sizeof(line)-1);
++ int bufsize = clamp((size_t)0, sizeof(line)-l, sizeof(line)-1);
+ fgets(&line[l-2], bufsize, fp);
diff --git a/games-simulation/cannonsmash/files/cannonsmash-0.6.6-x-inc.patch b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-x-inc.patch
new file mode 100644
index 000000000000..99c1e2f944fa
--- /dev/null
+++ b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-x-inc.patch
@@ -0,0 +1,18 @@
+Patch by Jason Bucata.
+http://bugs.gentoo.org/84187
+
+--- configure
++++ configure
+@@ -5515,7 +5515,11 @@
+ fi
+
+
+-CFLAGS="-I $x_includes"
++if test "x$x_includes" != "x"; then
++ CFLAGS="-I $x_includes"
++else
++ CFLAGS=""
++fi
+ LDFLAGS="-L/usr/local/lib -L$x_libraries -L$libdir"
+ CXXFLAGS="$CFLAGS -Wall"
+