summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-15 13:10:51 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-15 13:10:51 +0000
commit1d96058bcb1f9be46120983673c96dba6deee60d (patch)
tree5f425df60aa77c06df6125b502c7a88c4413fe26 /games-server
parentStable on ppc64; bug #221063 (diff)
downloadgentoo-2-1d96058bcb1f9be46120983673c96dba6deee60d.tar.gz
gentoo-2-1d96058bcb1f9be46120983673c96dba6deee60d.tar.bz2
gentoo-2-1d96058bcb1f9be46120983673c96dba6deee60d.zip
drop virtual/libc dep
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/mtavc/mtavc-0.5.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/games-server/mtavc/mtavc-0.5.ebuild b/games-server/mtavc/mtavc-0.5.ebuild
index fa6ebb71c136..8979fbe0ddc5 100644
--- a/games-server/mtavc/mtavc-0.5.ebuild
+++ b/games-server/mtavc/mtavc-0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/mtavc/mtavc-0.5.ebuild,v 1.1 2007/02/08 21:51:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/mtavc/mtavc-0.5.ebuild,v 1.2 2008/05/15 13:10:51 nyhm Exp $
inherit eutils games
@@ -12,10 +12,8 @@ LICENSE="as-is"
SLOT="0"
KEYWORDS="-* ~x86"
IUSE=""
-RESTRICT=""
-DEPEND="virtual/libc
- sys-libs/lib-compat"
+DEPEND="sys-libs/lib-compat"
S=${WORKDIR}
@@ -27,17 +25,17 @@ src_unpack() {
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
- dogamesbin ${FILESDIR}/mtavc
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/mtavc
+ dogamesbin "${FILESDIR}"/mtavc
+ dosed "s:GENTOO_DIR:${dir}:" "${GAMES_BINDIR}"/mtavc
- exeinto ${dir}
+ exeinto "${dir}"
newexe MTAServer${PV} MTAServer
- insinto ${GAMES_SYSCONFDIR}/${PN}
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
local files="banned.lst motd.txt mtaserver.conf"
doins ${files}
dodoc README CHANGELOG
for f in ${files} ; do
- dosym ${GAMES_SYSCONFDIR}/${PN}/${f} ${dir}/${f}
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/${f} "${dir}"/${f}
done
prepgamesdirs