summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-11-20 10:46:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-11-20 10:46:46 +0000
commit2cc094aa6138cd9cc58e838f9e112ff39908115a (patch)
tree2378ac842d404c5ec23f0055c13183d36540666f /games-server/cyphesis
parentx86 stable wrt #247557 (diff)
downloadgentoo-2-2cc094aa6138cd9cc58e838f9e112ff39908115a.tar.gz
gentoo-2-2cc094aa6138cd9cc58e838f9e112ff39908115a.tar.bz2
gentoo-2-2cc094aa6138cd9cc58e838f9e112ff39908115a.zip
Version bump to 0.5.17
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-server/cyphesis')
-rw-r--r--games-server/cyphesis/ChangeLog8
-rw-r--r--games-server/cyphesis/cyphesis-0.5.17.ebuild39
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.17-gentoo.patch29
3 files changed, 75 insertions, 1 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index a5fbe1a3f3ff..d03db362047d 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/cyphesis
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.6 2008/05/19 19:56:20 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.7 2008/11/20 10:46:46 tupone Exp $
+
+*cyphesis-0.5.17 (20 Nov 2008)
+
+ 20 Nov 2008; Alfredo Tupone <tupone@gentoo.org>
+ +files/cyphesis-0.5.17-gentoo.patch, +cyphesis-0.5.17.ebuild:
+ Version bump to 0.5.17
19 May 2008; Tiziano Müller <dev-zero@gentoo.org> cyphesis-0.5.15.ebuild:
Changed dependency for postgresql to virtual/postgresql-base
diff --git a/games-server/cyphesis/cyphesis-0.5.17.ebuild b/games-server/cyphesis/cyphesis-0.5.17.ebuild
new file mode 100644
index 000000000000..27c904ba560d
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.5.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.5.17.ebuild,v 1.1 2008/11/20 10:46:46 tupone Exp $
+
+inherit eutils autotools games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/skstream-0.3.6
+ >=dev-games/wfmath-0.3
+ =dev-games/mercator-0.2*
+ dev-libs/libgcrypt
+ =dev-libs/libsigc++-2.0*
+ =media-libs/atlas-c++-0.6*
+ >=media-libs/varconf-0.6.4
+ virtual/postgresql-base"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Patching to disable howl and avahi discovery
+ # To be removed when upstream will provide a way to selectively
+ # enable/disable supoort for it
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.5.17-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.5.17-gentoo.patch
new file mode 100644
index 000000000000..bc49faa836e7
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.17-gentoo.patch
@@ -0,0 +1,29 @@
+--- configure.ac.old 2007-01-31 23:22:11.000000000 +0100
++++ configure.ac 2007-01-31 23:22:40.000000000 +0100
+@@ -258,26 +258,6 @@
+ libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- PKG_CHECK_MODULES(HOWL, howl,
+- [
+- CPPFLAGS="$CPPFLAGS $HOWL_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $HOWL_LIBS"
+- AC_DEFINE(HAVE_LIBHOWL, 1, [Define to 1 if you have howl libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then