summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-08-02 14:00:15 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-08-02 14:00:15 +0000
commita2d5000f0f72fc79f1e33ce373f3e329492d0d99 (patch)
tree14778781e430b930414c4b4f4be8566538ff468e /games-rpg/nwmovies
parentVersion bump, see bug #231704. Massively simplified the ebuild since this ver... (diff)
downloadgentoo-2-a2d5000f0f72fc79f1e33ce373f3e329492d0d99.tar.gz
gentoo-2-a2d5000f0f72fc79f1e33ce373f3e329492d0d99.tar.bz2
gentoo-2-a2d5000f0f72fc79f1e33ce373f3e329492d0d99.zip
Version bump. Switched to using upstream's precompiled and tested binaries.
(Portage version: 2.2_rc5/cvs/Linux 2.6.25-gentoo-r6 i686)
Diffstat (limited to 'games-rpg/nwmovies')
-rw-r--r--games-rpg/nwmovies/ChangeLog9
-rw-r--r--games-rpg/nwmovies/nwmovies-0.1.ebuild3
-rw-r--r--games-rpg/nwmovies/nwmovies-0.2.ebuild60
3 files changed, 70 insertions, 2 deletions
diff --git a/games-rpg/nwmovies/ChangeLog b/games-rpg/nwmovies/ChangeLog
index 647665a321c0..4071a8d1a987 100644
--- a/games-rpg/nwmovies/ChangeLog
+++ b/games-rpg/nwmovies/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-rpg/nwmovies
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/ChangeLog,v 1.3 2008/05/29 14:26:47 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/ChangeLog,v 1.4 2008/08/02 14:00:15 calchan Exp $
+
+*nwmovies-0.2 (02 Aug 2008)
+
+ 02 Aug 2008; Denis Dupeyron <calchan@gentoo.org> nwmovies-0.1.ebuild,
+ +nwmovies-0.2.ebuild:
+ Version bump. Switched to using upstream's precompiled and tested
+ binaries.
29 May 2008; Christian Faulhammer <opfer@gentoo.org> nwmovies-0.1.ebuild:
stable x86, bug 222519
diff --git a/games-rpg/nwmovies/nwmovies-0.1.ebuild b/games-rpg/nwmovies/nwmovies-0.1.ebuild
index aa82465b96de..80e6efcf8d7c 100644
--- a/games-rpg/nwmovies/nwmovies-0.1.ebuild
+++ b/games-rpg/nwmovies/nwmovies-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/nwmovies-0.1.ebuild,v 1.4 2008/05/29 14:26:47 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/nwmovies-0.1.ebuild,v 1.5 2008/08/02 14:00:15 calchan Exp $
inherit eutils games
@@ -16,6 +16,7 @@ IUSE=""
DEPEND=">=games-rpg/nwn-data-1.29-r3"
RDEPEND="${DEPEND}
>=games-rpg/nwn-1.68-r4
+ !>=games-rpg/nwn-1.69
media-video/binkplayer"
S="${WORKDIR}"
diff --git a/games-rpg/nwmovies/nwmovies-0.2.ebuild b/games-rpg/nwmovies/nwmovies-0.2.ebuild
new file mode 100644
index 000000000000..43f2e8ad1312
--- /dev/null
+++ b/games-rpg/nwmovies/nwmovies-0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmovies/nwmovies-0.2.ebuild,v 1.1 2008/08/02 14:00:15 calchan Exp $
+
+inherit eutils games
+
+UPSTREAM_VERSION="nwmovies-v4-public.20080512.v4rc1"
+
+DESCRIPTION="Play Neverwinter Nights movies inside the Linux client."
+HOMEPAGE="http://home.woh.rr.com/nwmovies/"
+SRC_URI="${HOMEPAGE}${UPSTREAM_VERSION}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=games-rpg/nwn-data-1.29-r3"
+RDEPEND="${DEPEND}
+ >=games-rpg/nwn-1.68-r4
+ media-video/binkplayer"
+
+S="${WORKDIR}"
+DESTDIR="${GAMES_PREFIX_OPT}/nwn"
+
+QA_TEXTRELS="opt/nwn/nwmovies/binklib.so opt/nwn/nwmovies.so"
+QA_WX_LOAD="opt/nwn/nwmovies.so"
+QA_EXECSTACK="opt/nwn/nwmovies.so"
+QA_DT_HASH="opt/nwn/nwmovies/binklib.so opt/nwn/nwmovies/libdis/libdisasm.so opt/nwn/nwmovies.so"
+
+pkg_setup() {
+ games_pkg_setup
+ built_with_use games-rpg/nwn-data videos || die "nwn-data requires USE=videos"
+}
+
+src_install() {
+ exeinto "${DESTDIR}"
+ doexe nwmovies.so nwmovies.pl || die "Installation failed"
+ exeinto "${DESTDIR}/nwmovies"
+ doexe nwmovies/binklib.so || die "Installation failed"
+ exeinto "${DESTDIR}/nwmovies/libdis"
+ doexe nwmovies/libdis/libdisasm.so || die "Installation failed"
+ insinto "${DESTDIR}"
+ doins nwmovies/*.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "When starting nwn the next time, nwmovies will scan the nwmain"
+ elog "binary for its hooks, store this information in:"
+ elog " \${HOME}/.nwn/\${LANG}/nwmovies.ini"
+ elog "and exit. This is normal."
+ elog
+ elog "You will have to remove this file whenever you update nwn."
+ elog
+ elog "If you have sound issues in NWN only when using nwmovies, then"
+ elog "you may need to properly setup /etc/asound.conf or the equivalent"
+ elog "per-user \${HOME}/.asound.conf, see comment #31 in bug #106789."
+}