summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-02-21 02:59:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-02-21 02:59:37 +0000
commit94f99fddb75c84437ccc0d3c90cfde6cefbd88a3 (patch)
tree9af773a6e3196aacd8ce9a237243224cc40e3971 /games-puzzle
parentAdd ~arm-linux keyword. (diff)
downloadgentoo-2-94f99fddb75c84437ccc0d3c90cfde6cefbd88a3.tar.gz
gentoo-2-94f99fddb75c84437ccc0d3c90cfde6cefbd88a3.tar.bz2
gentoo-2-94f99fddb75c84437ccc0d3c90cfde6cefbd88a3.zip
update menu icon handling
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/wmpuzzle/ChangeLog6
-rw-r--r--games-puzzle/wmpuzzle/wmpuzzle-0.5.1.ebuild20
2 files changed, 21 insertions, 5 deletions
diff --git a/games-puzzle/wmpuzzle/ChangeLog b/games-puzzle/wmpuzzle/ChangeLog
index d56fd04809d8..ebb2372c22bd 100644
--- a/games-puzzle/wmpuzzle/ChangeLog
+++ b/games-puzzle/wmpuzzle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/wmpuzzle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wmpuzzle/ChangeLog,v 1.8 2013/01/20 12:24:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wmpuzzle/ChangeLog,v 1.9 2013/02/21 02:59:37 mr_bones_ Exp $
+
+ 21 Feb 2013; Michael Sterrett <mr_bones_@gentoo.org> wmpuzzle-0.5.1.ebuild:
+ update menu icon handling
*wmpuzzle-0.5.1 (20 Jan 2013)
@@ -31,4 +34,3 @@
17 Jan 2008; Samuli Suominen <ssuominen@gentoo.org> +wmpuzzle-0.5.0.ebuild:
Initial commit. Ebuild by Kenneth Prugh a.k.a. Ken69267
-
diff --git a/games-puzzle/wmpuzzle/wmpuzzle-0.5.1.ebuild b/games-puzzle/wmpuzzle/wmpuzzle-0.5.1.ebuild
index 0b3643e5d921..1aa3411baf3d 100644
--- a/games-puzzle/wmpuzzle/wmpuzzle-0.5.1.ebuild
+++ b/games-puzzle/wmpuzzle/wmpuzzle-0.5.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wmpuzzle/wmpuzzle-0.5.1.ebuild,v 1.1 2013/01/20 12:24:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/wmpuzzle/wmpuzzle-0.5.1.ebuild,v 1.2 2013/02/21 02:59:37 mr_bones_ Exp $
EAPI=5
-inherit eutils games
+inherit eutils gnome2-utils games
DESCRIPTION="wmpuzzle provides a 4x4 puzzle on a 64x64 mini window"
HOMEPAGE="http://freshmeat.net/projects/wmpuzzle"
@@ -26,9 +26,23 @@ src_install() {
dogamesbin ${PN}
dodoc ../{CHANGES,README}
- newicon numbers.xpm ${PN}.xpm
+ newicon -s 48 numbers.xpm ${PN}.xpm
doman ${PN}.6
make_desktop_entry ${PN}
prepgamesdirs
}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ games_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ games_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}