summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-03-13 22:04:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-03-13 22:04:26 +0000
commit694a314af3490e9dc094398c3e088ff39e0a7171 (patch)
tree3964d64ce9e349b5f832e16b258ee3f7769771a3 /games-puzzle
parentold (diff)
downloadgentoo-2-694a314af3490e9dc094398c3e088ff39e0a7171.tar.gz
gentoo-2-694a314af3490e9dc094398c3e088ff39e0a7171.tar.bz2
gentoo-2-694a314af3490e9dc094398c3e088ff39e0a7171.zip
version bump (bug #408053) with ebuild submission from yury fedorchenko
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/jag/ChangeLog9
-rw-r--r--games-puzzle/jag/jag-0.3.2.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/games-puzzle/jag/ChangeLog b/games-puzzle/jag/ChangeLog
index e6c9d45b0bc8..0a013d64da15 100644
--- a/games-puzzle/jag/ChangeLog
+++ b/games-puzzle/jag/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/jag
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/jag/ChangeLog,v 1.12 2011/06/18 17:50:22 tupone Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/jag/ChangeLog,v 1.13 2012/03/13 22:04:26 mr_bones_ Exp $
+
+*jag-0.3.2 (13 Mar 2012)
+
+ 13 Mar 2012; Michael Sterrett <mr_bones_@gentoo.org> +jag-0.3.2.ebuild:
+ version bump (bug #408053) with ebuild submission from yury fedorchenko
18 Jun 2011; Tupone Alfredo <tupone@gentoo.org> jag-0.3.1.ebuild:
Fix underlink. Bug #369311 by Diego Elio Pettenò
diff --git a/games-puzzle/jag/jag-0.3.2.ebuild b/games-puzzle/jag/jag-0.3.2.ebuild
new file mode 100644
index 000000000000..b3649bd1a6ea
--- /dev/null
+++ b/games-puzzle/jag/jag-0.3.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/jag/jag-0.3.2.ebuild,v 1.1 2012/03/13 22:04:26 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils qt4-r2 games
+
+DESCRIPTION="Arcade 2D Puzzle Game"
+HOMEPAGE="http://jag.xlabsoft.com/"
+SRC_URI="http://jag.xlabsoft.com/files/${P}-src.zip
+ http://jag.xlabsoft.com/files/${P}-data.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="editor"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+ x11-libs/libXrandr
+ media-libs/libsdl[audio,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ mv ${WORKDIR}/${P}-data/data ${WORKDIR}/${P}-src/
+ sed -i \
+ -e "s:/usr/local/bin:${GAMES_BINDIR}:g" \
+ -e "s:/usr/local/games:${GAMES_DATADIR}:g" \
+ -e "s:LIBS += -lSDLmain:LIBS += -lSDL -lX11:" \
+ Game.pro main.cpp editor/editor.pro \
+ || die "sed failed"
+}
+
+src_configure() {
+ qt4-r2_src_configure
+ if use editor; then
+ cd editor
+ eqmake4 editor.pro
+ fi
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use editor; then
+ cd editor
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ qt4-r2_src_install
+ newicon images/logo.png ${PN}.png
+ make_desktop_entry jag Jag
+
+ if use editor; then
+ cd editor
+ qt4-r2_src_install
+ make_desktop_entry jag-editor "Jag Level editor" ${PN}
+ fi
+
+ prepgamesdirs
+}