summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-09-28 12:24:34 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-09-28 12:24:34 +0000
commit1406987aaccd75affa39a637442da2d0f6612358 (patch)
tree4bbfb8db0f59ab0ec8df51831a920e980a1993ff /games-puzzle
parentStable for x86, wrt bug #436072 (diff)
downloadgentoo-2-1406987aaccd75affa39a637442da2d0f6612358.tar.gz
gentoo-2-1406987aaccd75affa39a637442da2d0f6612358.tar.bz2
gentoo-2-1406987aaccd75affa39a637442da2d0f6612358.zip
Fix build with gcc-4.7. Bug #424133
Adding USE dependency on sdl-image. Bug #406857 (Portage version: 2.1.11.21/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/enigma/ChangeLog9
-rw-r--r--games-puzzle/enigma/enigma-1.01.ebuild7
-rw-r--r--games-puzzle/enigma/files/enigma-1.01-gcc47.patch11
3 files changed, 22 insertions, 5 deletions
diff --git a/games-puzzle/enigma/ChangeLog b/games-puzzle/enigma/ChangeLog
index d0e63ea38eb2..8026bcfb914d 100644
--- a/games-puzzle/enigma/ChangeLog
+++ b/games-puzzle/enigma/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/enigma
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.51 2011/09/15 02:16:23 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.52 2012/09/28 12:24:34 tupone Exp $
+
+ 28 Sep 2012; Tupone Alfredo <tupone@gentoo.org> enigma-1.01.ebuild,
+ +files/enigma-1.01-gcc47.patch:
+ Fix build with gcc-4.7. Bug #424133 by Diego
+ Adding USE dependency on sdl-image. Bug #406857 by Bryan Gardiner
15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> enigma-1.01.ebuild,
+files/enigma-1.01-libpng15.patch:
diff --git a/games-puzzle/enigma/enigma-1.01.ebuild b/games-puzzle/enigma/enigma-1.01.ebuild
index 44ccada8a3ec..59805e93bf91 100644
--- a/games-puzzle/enigma/enigma-1.01.ebuild
+++ b/games-puzzle/enigma/enigma-1.01.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.16 2011/09/15 02:16:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.17 2012/09/28 12:24:34 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -17,7 +17,7 @@ IUSE="nls"
RDEPEND="media-libs/sdl-ttf
media-libs/libsdl
media-libs/sdl-mixer
- media-libs/sdl-image[png]
+ media-libs/sdl-image[jpeg,png]
media-libs/libpng
|| ( >=dev-libs/xerces-c-3[icu] >=dev-libs/xerces-c-3[-icu,-iconv] )
net-libs/enet:0
@@ -32,6 +32,7 @@ src_prepare() {
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-xerces-c.patch \
"${FILESDIR}"/${P}-libpng15.patch
eautoreconf
diff --git a/games-puzzle/enigma/files/enigma-1.01-gcc47.patch b/games-puzzle/enigma/files/enigma-1.01-gcc47.patch
new file mode 100644
index 000000000000..622b2a14c6ce
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-1.01-gcc47.patch
@@ -0,0 +1,11 @@
+--- lib-src/enigma-core/ecl_alist.hh.old 2012-09-28 12:28:01.465223434 +0200
++++ lib-src/enigma-core/ecl_alist.hh 2012-09-28 12:28:41.195739039 +0200
+@@ -61,7 +61,7 @@
+ VAL &operator[] (const key_type &key) {
+ iterator i=find(key);
+ if (i==this->end())
+- i=insert(this->end(), make_pair(key, VAL()));
++ i=this->insert(this->end(), make_pair(key, VAL()));
+ return i->second;
+ }
+ };