summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-14 03:53:28 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-14 03:53:28 +0000
commit690bbf98ae49780c366603dab80721b66dd4c4f3 (patch)
tree7d8039e3cd082ab1f315d2034bb4e0484d549ceb /games-puzzle/fbg/fbg-0.9-r1.ebuild
parentold (diff)
downloadgentoo-2-690bbf98ae49780c366603dab80721b66dd4c4f3.tar.gz
gentoo-2-690bbf98ae49780c366603dab80721b66dd4c4f3.tar.bz2
gentoo-2-690bbf98ae49780c366603dab80721b66dd4c4f3.zip
fix install
Diffstat (limited to 'games-puzzle/fbg/fbg-0.9-r1.ebuild')
-rw-r--r--games-puzzle/fbg/fbg-0.9-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/fbg/fbg-0.9-r1.ebuild b/games-puzzle/fbg/fbg-0.9-r1.ebuild
new file mode 100644
index 000000000000..e126fcd5bf1d
--- /dev/null
+++ b/games-puzzle/fbg/fbg-0.9-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fbg/fbg-0.9-r1.ebuild,v 1.1 2003/09/14 03:53:28 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A tetris-clone written in OpenGL"
+HOMEPAGE="http://home.attbi.com/~furiousjay/code/fbg.html"
+SRC_URI="mirror://sourceforge/fbg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ virtual/glu
+ >=dev-games/physfs-0.1.7
+ >=media-libs/libsdl-1.2.0
+ >=media-libs/libmikmod-3.1.10"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "/FBGDATADIR=/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" configure
+}
+
+src_compile() {
+ egamesconf --disable-fbglaunch || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README TODO AUTHORS
+
+ # now clean up the install
+ cd ${D}/${GAMES_PREFIX}
+ rm -rf doc
+ mv games ../share/
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "less /usr/share/doc/${PF}/README.gz for play-instructions"
+}