summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-26 11:16:55 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-26 11:16:55 +0000
commite93e95bcbe20d0f1e11c49593012638b385f3ec2 (patch)
tree2cde062b51415c6f6d1d8aa58be3d63cf8a98c54 /games-misc
parentFix bashism in Makefile.in (bug #526906). (diff)
downloadgentoo-2-e93e95bcbe20d0f1e11c49593012638b385f3ec2.tar.gz
gentoo-2-e93e95bcbe20d0f1e11c49593012638b385f3ec2.tar.bz2
gentoo-2-e93e95bcbe20d0f1e11c49593012638b385f3ec2.zip
EAPI bump. Fix building against sys-libs/ncurses[tinfo] (bug #526798).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/bsod/ChangeLog8
-rw-r--r--games-misc/bsod/bsod-0.1.ebuild18
-rw-r--r--games-misc/bsod/files/bsod-0.1-Makefile.patch8
3 files changed, 20 insertions, 14 deletions
diff --git a/games-misc/bsod/ChangeLog b/games-misc/bsod/ChangeLog
index 57cb7b8310a3..689d7159cb8e 100644
--- a/games-misc/bsod/ChangeLog
+++ b/games-misc/bsod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/bsod
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/bsod/ChangeLog,v 1.3 2012/08/01 12:38:09 kensington Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/bsod/ChangeLog,v 1.4 2014/10/26 11:16:55 jer Exp $
+
+ 26 Oct 2014; Jeroen Roovers <jer@gentoo.org> bsod-0.1.ebuild,
+ files/bsod-0.1-Makefile.patch:
+ EAPI bump. Fix building against sys-libs/ncurses[tinfo] (bug #526798).
01 Aug 2012; Michael Palimaka <kensington@gentoo.org> bsod-0.1.ebuild:
Stable for amd64 wrt bug #426748, thanks to Elijah "Armageddon" El Lazkani.
diff --git a/games-misc/bsod/bsod-0.1.ebuild b/games-misc/bsod/bsod-0.1.ebuild
index 09bcb70c07d8..cf162f483641 100644
--- a/games-misc/bsod/bsod-0.1.ebuild
+++ b/games-misc/bsod/bsod-0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/bsod/bsod-0.1.ebuild,v 1.4 2012/08/01 12:38:09 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/bsod/bsod-0.1.ebuild,v 1.5 2014/10/26 11:16:55 jer Exp $
-EAPI=2
-inherit eutils games
+EAPI=5
+inherit eutils games toolchain-funcs
DESCRIPTION="This program will let you UNIX user experience the authentic microsoft windows experience"
HOMEPAGE="http://www.vanheusden.com/bsod/"
@@ -12,16 +12,20 @@ SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-DEPEND="sys-libs/ncurses"
+RDEPEND="sys-libs/ncurses"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
src_prepare() {
epatch "${FILESDIR}"/${P}-Makefile.patch
+ tc-export PKG_CONFIG
}
src_install() {
- dogamesbin ${PN} || die
+ dogamesbin ${PN}
dodoc Changes
prepgamesdirs
diff --git a/games-misc/bsod/files/bsod-0.1-Makefile.patch b/games-misc/bsod/files/bsod-0.1-Makefile.patch
index a415ddf07207..b7699c80403b 100644
--- a/games-misc/bsod/files/bsod-0.1-Makefile.patch
+++ b/games-misc/bsod/files/bsod-0.1-Makefile.patch
@@ -1,14 +1,12 @@
-Extended version of this patch was sent to mail address in bsod-0.1/readme.txt
-
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -1,15 +1,15 @@
VERSION=0.1
DEBUG=-g -pedantic #-pg #-fprofile-arcs
-LDFLAGS=-lncurses $(DEBUG)
-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
-+LDLIBS=-lncurses
++LDLIBS=$(shell ${PKG_CONFIG} --libs ncurses)
+CFLAGS+=-Wall -DVERSION=\"$(VERSION)\"
OBJS=bsod.o