summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-13 09:16:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-13 09:16:49 +0000
commit5afe21d1678a44754e16f70e453cc84027a4a095 (patch)
tree782ca1120c6bd43ac1eedbe7fb416d6c512e64f8 /games-misc
parentsecurity bump to stable (Manifest recommit) (diff)
downloadgentoo-2-5afe21d1678a44754e16f70e453cc84027a4a095.tar.gz
gentoo-2-5afe21d1678a44754e16f70e453cc84027a4a095.tar.bz2
gentoo-2-5afe21d1678a44754e16f70e453cc84027a4a095.zip
off into function; error check sed; E_CFLAGS; error messages
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/fortune-mod/ChangeLog6
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1.ebuild27
2 files changed, 21 insertions, 12 deletions
diff --git a/games-misc/fortune-mod/ChangeLog b/games-misc/fortune-mod/ChangeLog
index 9e14248a4f33..0a53a2bc4876 100644
--- a/games-misc/fortune-mod/ChangeLog
+++ b/games-misc/fortune-mod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/fortune-mod
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/ChangeLog,v 1.5 2004/05/13 08:10:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/ChangeLog,v 1.6 2004/05/13 09:16:49 mr_bones_ Exp $
+
+ 13 May 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ fortune-mod-1.99.1.ebuild:
+ off into function; error check sed; E_CFLAGS; error messages
13 May 2004; Michael Sterrett <mr_bones_@gentoo.org>
fortune-mod-1.0.9708-r1.ebuild:
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1.ebuild
index 7dffb0871c9a..e4a7f622ecc8 100644
--- a/games-misc/fortune-mod/fortune-mod-1.99.1.ebuild
+++ b/games-misc/fortune-mod/fortune-mod-1.99.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1.ebuild,v 1.2 2004/05/13 07:52:01 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1.ebuild,v 1.3 2004/05/13 09:16:49 mr_bones_ Exp $
inherit eutils
@@ -16,8 +16,6 @@ IUSE="offensive"
DEPEND="virtual/glibc
app-text/recode"
-[ `use offensive` ] && off=1 || off=0
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -26,22 +24,29 @@ src_unpack() {
-e 's:/games::' \
-e 's:/fortunes:/fortune:' \
-e 's:FORTDIR=$(prefix)/usr:FORTDIR=$(prefix)/usr/bin:' \
- -e "s:^CFLAGS=.*$:CFLAGS=\$(DEFINES) ${CFLAGS}:" \
- Makefile
- sed -i 's:char a, b;:short int a, b;:' util/rot.c
+ -e 's:^CFLAGS=.*$:CFLAGS=$(DEFINES) $(E_CFLAGS):' \
+ Makefile \
+ || die "sed Makefile failed"
+ sed -i \
+ -e 's:char a, b;:short int a, b;:' util/rot.c \
+ || die "sed util/rot.c failed"
- # fixes the '-m' segfault problem on _my_ computer, it might screw something else up i don't know about.
+ # fixes the '-m' segfault problem on _my_ computer,
+ # it might screw something else up i don't know about.
sed -i \
- '/if (fp->utf8_charset)/{
+ -e '/if (fp->utf8_charset)/{
N
/free (output);/d
- }' fortune/fortune.c
+ }' fortune/fortune.c \
+ || die "sed fortune/fortune.c failed"
+ use offensive && off=1 || off=0
}
src_compile() {
emake \
+ E_CFLAGS="${CFLAGS}" \
OFFENSIVE="${off}" \
- || die
+ || die "emake failed"
}
src_install() {
@@ -49,7 +54,7 @@ src_install() {
OFFENSIVE="${off}" \
prefix="${D}" \
install \
- || die
+ || die "make install failed"
dodoc ChangeLog INDEX INSTALL Notes Offensive README TODO cookie-files
}