summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-11-06 01:34:10 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-11-06 01:34:10 +0000
commit0fa111b1318dd13399c57d9413e47974664bd743 (patch)
tree8a70c5dd0ab1dacf31ef86034b1af0d825a408fb /games-misc
parentStable for HPPA (bug #528208). (diff)
downloadgentoo-2-0fa111b1318dd13399c57d9413e47974664bd743.tar.gz
gentoo-2-0fa111b1318dd13399c57d9413e47974664bd743.tar.bz2
gentoo-2-0fa111b1318dd13399c57d9413e47974664bd743.zip
maybe fix bug #528086
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/katawa-shoujo/ChangeLog7
-rw-r--r--games-misc/katawa-shoujo/katawa-shoujo-1.2-r1.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/games-misc/katawa-shoujo/ChangeLog b/games-misc/katawa-shoujo/ChangeLog
index a924a7e95847..3ed5d84502eb 100644
--- a/games-misc/katawa-shoujo/ChangeLog
+++ b/games-misc/katawa-shoujo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/katawa-shoujo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/ChangeLog,v 1.8 2014/07/28 22:36:17 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/ChangeLog,v 1.9 2014/11/06 01:34:10 hasufell Exp $
+
+*katawa-shoujo-1.2-r1 (06 Nov 2014)
+
+ 06 Nov 2014; Julian Ospald <hasufell@gentoo.org> +katawa-shoujo-1.2-r1.ebuild:
+ maybe fix bug #528086
*katawa-shoujo-1.2 (28 Jul 2014)
diff --git a/games-misc/katawa-shoujo/katawa-shoujo-1.2-r1.ebuild b/games-misc/katawa-shoujo/katawa-shoujo-1.2-r1.ebuild
new file mode 100644
index 000000000000..6e0b6f901a63
--- /dev/null
+++ b/games-misc/katawa-shoujo/katawa-shoujo-1.2-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/katawa-shoujo-1.2-r1.ebuild,v 1.1 2014/11/06 01:34:10 hasufell Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Bishoujo-style visual novel set in the fictional Yamaku High School for disabled children"
+HOMEPAGE="http://katawa-shoujo.com/"
+SRC_URI="http://dl.katawa-shoujo.com/gold_1.2/%5b4ls%5d_katawa_shoujo_1.2-%5blinux-x86%5d%5b8F3BA490%5d.tar.bz2 -> ${P}.tar.bz2
+ http://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-48.png
+ http://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-256.png"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc system-renpy"
+
+DEPEND="dev-util/patchelf"
+
+# make system-renpy optional due to #459742 :(
+RDEPEND="system-renpy? ( games-engines/renpy )
+ !system-renpy? (
+ || (
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+ )" #495270
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/lib/*"
+
+S="${WORKDIR}/Katawa Shoujo-linux-x86"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #528086).
+ local x
+ while read -r x ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath \
+ "${EPREFIX}${GAMES_PREFIX_OPT}/${PN}/lib" "${x}" || \
+ die "patchelf failed on ${x}"
+ done < <(find . -type f)
+}
+
+src_install() {
+ if use system-renpy ; then
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r game/.
+ games_make_wrapper ${PN} "renpy '${GAMES_DATADIR}/${PN}'"
+ else
+ insinto "${GAMES_PREFIX_OPT}"/${PN}
+ doins -r common game lib renpy "Katawa Shoujo.py" "Katawa Shoujo.sh"
+ games_make_wrapper ${PN} "./Katawa\ Shoujo.sh" "${GAMES_PREFIX_OPT}/${PN}"
+ fperms +x "${GAMES_PREFIX_OPT}/${PN}"/lib/{python,linux-x86/python.real} \
+ "${GAMES_PREFIX_OPT}/${PN}/Katawa Shoujo.sh" \
+ "${GAMES_PREFIX_OPT}/${PN}/Katawa Shoujo.py"
+ fi
+
+ local i
+ for i in 48 256; do
+ newicon -s ${i} "${DISTDIR}"/${PN}-${i}.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} "Katawa Shoujo"
+
+ if use doc ; then
+ newdoc "Game Manual.pdf" manual.pdf
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "Savegames from system-renpy and the bundled version are incompatible"
+
+ if use system-renpy; then
+ ewarn "system-renpy is unstable and not supported upstream"
+ fi
+
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}