summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-11 06:34:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-11 06:34:40 +0000
commitefa8963547bd9721fce069a19c9464c72fc31d50 (patch)
tree2e8f598999e1393e4d41cc54c43035438f599875 /games-kids
parentCleaning old version (diff)
downloadgentoo-2-efa8963547bd9721fce069a19c9464c72fc31d50.tar.gz
gentoo-2-efa8963547bd9721fce069a19c9464c72fc31d50.tar.bz2
gentoo-2-efa8963547bd9721fce069a19c9464c72fc31d50.zip
version bump - ebuild submitted by Jonathan via bug #210054
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/tuxmath/ChangeLog10
-rw-r--r--games-kids/tuxmath/tuxmath-1.7.2.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/games-kids/tuxmath/ChangeLog b/games-kids/tuxmath/ChangeLog
index e3bffdf8236e..a4e31069a2b2 100644
--- a/games-kids/tuxmath/ChangeLog
+++ b/games-kids/tuxmath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-kids/tuxmath
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/ChangeLog,v 1.10 2009/04/30 20:35:56 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/ChangeLog,v 1.11 2009/10/11 06:34:40 mr_bones_ Exp $
+
+*tuxmath-1.7.2 (11 Oct 2009)
+
+ 11 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +tuxmath-1.7.2.ebuild:
+ version bump - ebuild submitted by Jonathan via bug #210054
30 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org>
tuxmath-20010907.ebuild:
diff --git a/games-kids/tuxmath/tuxmath-1.7.2.ebuild b/games-kids/tuxmath/tuxmath-1.7.2.ebuild
new file mode 100644
index 000000000000..4886c05d6b7c
--- /dev/null
+++ b/games-kids/tuxmath/tuxmath-1.7.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/tuxmath-1.7.2.ebuild,v 1.1 2009/10/11 06:34:40 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_PN="${PN}_w_fonts"
+DESCRIPTION="Educational arcade game where you have to solve maths problems"
+HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/"
+SRC_URI="mirror://sourceforge/tuxmath/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mikmod]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -i \
+ -e '/\bdoc\b/d' \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon data/images/icons/${PN}.svg
+ make_desktop_entry ${PN} "TuxMath"
+ dodoc doc/{README.txt,TODO.txt,changelog}
+ prepgamesdirs
+}