summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-25 17:23:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-25 17:23:51 +0000
commitfdfd7df2be1cce6bc748de3ca1a1a00379f9c488 (patch)
tree6bfb273ede98d9e4d2c287743c3a7ceeca45c4ba /games-fps
parentAdd ruby22. (diff)
downloadgentoo-2-fdfd7df2be1cce6bc748de3ca1a1a00379f9c488.tar.gz
gentoo-2-fdfd7df2be1cce6bc748de3ca1a1a00379f9c488.tar.bz2
gentoo-2-fdfd7df2be1cce6bc748de3ca1a1a00379f9c488.zip
EAPI=5; work with newer versions of patch (bug #544480)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/aaquake2/ChangeLog9
-rw-r--r--games-fps/aaquake2/aaquake2-0.1.ebuild31
-rw-r--r--games-fps/aaquake2/files/0.1-gentoo.patch16
-rw-r--r--games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch8
-rw-r--r--games-fps/aaquake2/files/aaquake2-0.1-glibc.patch8
-rw-r--r--games-fps/aaquake2/files/aaquake2-0.1-ldflags.patch4
6 files changed, 40 insertions, 36 deletions
diff --git a/games-fps/aaquake2/ChangeLog b/games-fps/aaquake2/ChangeLog
index c2fcfdd6efa5..8fc289e3c107 100644
--- a/games-fps/aaquake2/ChangeLog
+++ b/games-fps/aaquake2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/aaquake2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/ChangeLog,v 1.9 2010/09/21 09:11:01 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/ChangeLog,v 1.10 2015/03/25 17:23:51 mr_bones_ Exp $
+
+ 25 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> aaquake2-0.1.ebuild,
+ files/0.1-gentoo.patch, files/aaquake2-0.1-gcc41.patch,
+ files/aaquake2-0.1-glibc.patch, files/aaquake2-0.1-ldflags.patch:
+ EAPI=5; work with newer versions of patch (bug #544480)
21 Sep 2010; Tupone Alfredo <tupone@gentoo.org> files/0.1-gentoo.patch,
aaquake2-0.1.ebuild, files/aaquake2-0.1-gcc41.patch,
diff --git a/games-fps/aaquake2/aaquake2-0.1.ebuild b/games-fps/aaquake2/aaquake2-0.1.ebuild
index b0096cd25758..f66373409ab7 100644
--- a/games-fps/aaquake2/aaquake2-0.1.ebuild
+++ b/games-fps/aaquake2/aaquake2-0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.13 2010/10/13 21:23:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.14 2015/03/25 17:23:51 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils games
DESCRIPTION="text mode Quake II"
@@ -22,43 +22,42 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/quake2-3.21/linux
src_prepare() {
- epatch \
+ cd .. && epatch \
"${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc41.patch
+ cd "${S}" && epatch \
"${FILESDIR}"/${P}-glibc.patch \
- "${FILESDIR}"/${P}-gcc41.patch \
"${FILESDIR}"/${P}-ldflags.patch
sed -i \
- -e "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" sys_linux.c \
- || die "sed failed"
+ -e "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" sys_linux.c || die
sed -i \
-e "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" \
- sys_linux.c vid_so.c \
- || die "sed failed"
+ sys_linux.c vid_so.c || die
}
src_compile() {
mkdir -p releasei386-glibc/ref_soft
- make \
+ emake -j1 \
GENTOO_CFLAGS="${CFLAGS}" \
GENTOO_DATADIR="${GAMES_DATADIR}"/quake2/baseq2/ \
- build_release || die
+ build_release
}
src_install() {
- cd release*
+ cd release* || die
exeinto "$(games_get_libdir)"/${PN}
- doexe gamei386.so ref_softaa.so || die "doexe failed"
+ doexe gamei386.so ref_softaa.so
dosym ref_softaa.so "$(games_get_libdir)"/${PN}/ref_softx.so
dosym ref_softaa.so "$(games_get_libdir)"/${PN}/ref_soft.so
exeinto "$(games_get_libdir)"/${PN}/ctf
- doexe ctf/gamei386.so || die "doexe failed"
+ doexe ctf/gamei386.so
- newgamesbin quake2 aaquake2 || die "newgamesbin failed"
+ newgamesbin quake2 aaquake2
insinto "${GAMES_SYSCONFDIR}"
echo "$(games_get_libdir)"/${PN} > ${PN}.conf
- doins ${PN}.conf || die "doins failed"
+ doins ${PN}.conf
prepgamesdirs
}
diff --git a/games-fps/aaquake2/files/0.1-gentoo.patch b/games-fps/aaquake2/files/0.1-gentoo.patch
index 4a9b38bf5ecb..cc7bb1733f64 100644
--- a/games-fps/aaquake2/files/0.1-gentoo.patch
+++ b/games-fps/aaquake2/files/0.1-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2001-12-29 20:37:22.000000000 -0500
-+++ Makefile 2003-07-17 22:14:50.000000000 -0400
+--- linux/Makefile.old
++++ linux/Makefile
@@ -54,7 +54,7 @@
RELEASE_CFLAGS=$(BASE_CFLAGS) -O6 -ffast-math -funroll-loops \
-fomit-frame-pointer -fexpensive-optimizations
@@ -40,8 +40,8 @@
$(BUILD_RELEASE_DIR)/game \
$(BUILD_RELEASE_DIR)/ctf \
# $(BUILD_RELEASE_DIR)/xatrix \
---- sys_linux.c.old 2001-12-22 18:45:58.000000000 -0500
-+++ sys_linux.c 2003-07-17 22:34:11.000000000 -0400
+--- linux/sys_linux.c.old
++++ linux/sys_linux.c
@@ -220,7 +220,7 @@
char curpath[MAX_OSPATH];
char *path;
@@ -66,8 +66,8 @@
}
}
---- ../qcommon/files.c.old 2001-12-22 16:32:26.000000000 -0500
-+++ ../qcommon/files.c 2003-07-17 22:34:29.000000000 -0400
+--- qcommon/files.c.old
++++ qcommon/files.c
@@ -865,7 +865,7 @@
//
// start up with baseq2 by default
@@ -77,8 +77,8 @@
// any set gamedirs will be freed up to here
fs_base_searchpaths = fs_searchpaths;
---- ../qcommon/qcommon.h.old 2001-12-22 16:32:26.000000000 -0500
-+++ ../qcommon/qcommon.h 2003-07-17 21:20:03.000000000 -0400
+--- qcommon/qcommon.h.old
++++ qcommon/qcommon.h
@@ -25,7 +25,7 @@
#define VERSION 3.21
diff --git a/games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch b/games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch
index f3d3da6cad63..bb2e8e5979e5 100644
--- a/games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch
+++ b/games-fps/aaquake2/files/aaquake2-0.1-gcc41.patch
@@ -1,5 +1,5 @@
---- ../game/g_local.h.old 2006-05-05 21:26:25.000000000 +0200
-+++ ../game/g_local.h 2006-05-05 21:26:48.000000000 +0200
+--- game/g_local.h.old
++++ game/g_local.h
@@ -458,11 +458,6 @@
extern int sm_meat_index;
extern int snd_fry;
@@ -12,8 +12,8 @@
// means of death
#define MOD_UNKNOWN 0
#define MOD_BLASTER 1
---- ../ctf/g_local.h.old 2006-05-05 21:41:10.000000000 +0200
-+++ ../ctf/g_local.h 2006-05-05 21:41:23.000000000 +0200
+--- ctf/g_local.h.old
++++ ctf/g_local.h
@@ -466,11 +466,6 @@
extern int sm_meat_index;
extern int snd_fry;
diff --git a/games-fps/aaquake2/files/aaquake2-0.1-glibc.patch b/games-fps/aaquake2/files/aaquake2-0.1-glibc.patch
index 580df210d472..638e91b2c393 100644
--- a/games-fps/aaquake2/files/aaquake2-0.1-glibc.patch
+++ b/games-fps/aaquake2/files/aaquake2-0.1-glibc.patch
@@ -1,5 +1,5 @@
---- rw_aa.c.old 2008-03-18 23:29:28.000000000 +0100
-+++ rw_aa.c 2008-03-18 23:29:44.000000000 +0100
+--- rw_aa.c.old
++++ rw_aa.c
@@ -61,7 +61,7 @@
#include <signal.h>
#include <sys/mman.h>
@@ -9,8 +9,8 @@
#include <aalib.h>
---- rw_in_aa.c.old 2008-03-18 23:29:33.000000000 +0100
-+++ rw_in_aa.c 2008-03-18 23:29:54.000000000 +0100
+--- rw_in_aa.c.old
++++ rw_in_aa.c
@@ -46,7 +46,7 @@
#include <signal.h>
#include <sys/mman.h>
diff --git a/games-fps/aaquake2/files/aaquake2-0.1-ldflags.patch b/games-fps/aaquake2/files/aaquake2-0.1-ldflags.patch
index 3c011f8a6851..dc2359ac48d7 100644
--- a/games-fps/aaquake2/files/aaquake2-0.1-ldflags.patch
+++ b/games-fps/aaquake2/files/aaquake2-0.1-ldflags.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2010-09-21 10:43:43.000000000 +0200
-+++ Makefile 2010-09-21 10:47:26.000000000 +0200
+--- Makefile.old
++++ Makefile
@@ -59,7 +59,7 @@
endif