summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-06 13:07:04 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-06 13:07:04 +0000
commit66d5c3716646cd93fa05916c972641a1bf075476 (patch)
treea0fb6ee7ff81cf7f7847138dd762ef3d689ae213 /games-fps
parentBug 114468 - or clause was backwards (diff)
downloadgentoo-2-66d5c3716646cd93fa05916c972641a1bf075476.tar.gz
gentoo-2-66d5c3716646cd93fa05916c972641a1bf075476.tar.bz2
gentoo-2-66d5c3716646cd93fa05916c972641a1bf075476.zip
Version bumped to 20051119 and closing bug #113947.
(Portage version: 2.0.53)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/ChangeLog8
-rw-r--r--games-fps/alephone/Manifest9
-rw-r--r--games-fps/alephone/alephone-20051119.ebuild114
-rw-r--r--games-fps/alephone/files/alephone.pngbin0 -> 13265 bytes
-rw-r--r--games-fps/alephone/files/digest-alephone-200511191
5 files changed, 128 insertions, 4 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index e83945aea3b5..3ac2160f488b 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alephone
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.5 2005/09/26 18:10:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.6 2005/12/06 13:07:04 wolf31o2 Exp $
+
+*alephone-20051119 (06 Dec 2005)
+
+ 06 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org> +files/alephone.png,
+ +alephone-20051119.ebuild:
+ Version bumped to 20051119 and closing bug #113947.
26 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org>
alephone-20040417.ebuild:
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
index d7608bdab4aa..77df93144ab6 100644
--- a/games-fps/alephone/Manifest
+++ b/games-fps/alephone/Manifest
@@ -1,7 +1,10 @@
-MD5 7dd98ee7fc44a716dd68698c889b7d0a alephone-20050118.ebuild 1439
-MD5 5c48ad21c4f27240450eb064587c827d alephone-20040417.ebuild 1175
MD5 dd57db0ada396d64adcdd1328ed904a4 ChangeLog 873
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 5c48ad21c4f27240450eb064587c827d alephone-20040417.ebuild 1175
+MD5 7dd98ee7fc44a716dd68698c889b7d0a alephone-20050118.ebuild 1439
+MD5 8f38ede50b6d4ed36262aa04a4cdcbdc alephone-20051119.ebuild 2712
MD5 7c6943e706d040641031e7d8325b4e74 files/20040417-gcc34.patch 1567
+MD5 b3bde37a338d65ac0dec3aa0ac7c2c22 files/alephone.png 13265
MD5 d066c158a9be84eb6b74e20a66370581 files/digest-alephone-20040417 68
MD5 adc3c7e48da56c50654521b80fe2f0e2 files/digest-alephone-20050118 68
+MD5 e24c7221989a38e3bf31e9bd2bbeeb29 files/digest-alephone-20051119 70
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
diff --git a/games-fps/alephone/alephone-20051119.ebuild b/games-fps/alephone/alephone-20051119.ebuild
new file mode 100644
index 000000000000..fc1831fea443
--- /dev/null
+++ b/games-fps/alephone/alephone-20051119.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20051119.ebuild,v 1.1 2005/12/06 13:07:04 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl speex"
+
+DEPEND="lua? ( dev-lang/lua )
+ opengl? ( virtual/opengl )
+ speex? ( media-libs/speex )
+ dev-libs/boost
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-image
+ media-libs/sdl-net"
+
+S=${WORKDIR}/AlephOne-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/alephone.png ${S}
+ cat > ${S}/alephone.sh << EOF
+#!/bin/sh
+
+DATADIRS="
+/usr/local/share/AlephOne
+/usr/local/share/games/AlephOne
+/opt/AlephOne/share/AlephOne
+/opt/AlephOne/share/games/AlephOne
+/opt/alephone/share/AlephOne
+/opt/alephone/share/games/AlephOne
+/usr/share/AlephOne
+/usr/share/games/AlephOne"
+
+DIR=\$(dirname \${0})
+CMD=\$(basename \${0})
+ALEPHONE=\${CMD%%-*}
+GAME=\${CMD#*-}
+GAME=\${GAME%.*}
+
+if [ -n "\${ALEPHONE_DATA}" ]
+then
+ export ALEPHONE_DATA=\${ALEPHONE_DATA}:${GAMES_DATADIR}/alephone-\${GAME}
+elif [ "\${ALEPHONE}" == "alephone" ]
+then
+ export ALEPHONE_DATA=${GAMES_DATADIR}/AlephOne:${GAMES_DATADIR}/alephone-\${GAME}
+else
+ for d in \${DATADIRS}
+ do
+ if [ -d \${d} ]
+ then
+ export ALEPHONE_DATA=\${d}:${GAMES_DATADIR}/alephone-\${GAME}
+ break
+ fi
+ done
+ if [ -z "\${ALEPHONE_DATA}" ]
+ then
+ echo "Could not find the \${ALEPHONE} data directory in \${DATADIRS}"
+ echo "Please set your ALEPHONE_DATA variable to point to the correct location of the data directory for \${ALEPHONE}"
+ export ALEPHONE_DATA=${GAMES_DATADIR}/alephone-\${GAME}
+ fi
+fi
+
+\${DIR}/\${ALEPHONE} -m $*
+EOF
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable opengl) || die
+ if ! use lua ; then
+ # stupid configure script doesnt have an option
+ dosed -i \
+ -e '/HAVE_LUA/d' config.h \
+ || die "sed HAVE_LUA"
+ dosed -i \
+ -e '/^LIBS/s:-llua -llualib::' $(find -name Makefile) \
+ || die "sed -llua"
+ fi
+ if ! use speex ; then
+ # stupid configure script doesnt have an option
+ dosed -i \
+ -e '/SPEEX/d:' config.h \
+ || die "sed SPEEX"
+ dosed -i \
+ -e '/^LIBS/s:-lspeex::' $(find -name Makefile) \
+ || die "sed -lspeex"
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dogamesbin alephone.sh || die "failed to install wrapper"
+ dodoc AUTHORS README COPYING docs/Cheat_Codes
+ dohtml docs/MML.html
+ doicon alephone.png
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "Read the docs and install the data files accordingly to play."
+ echo
+}
diff --git a/games-fps/alephone/files/alephone.png b/games-fps/alephone/files/alephone.png
new file mode 100644
index 000000000000..1939cca6101e
--- /dev/null
+++ b/games-fps/alephone/files/alephone.png
Binary files differ
diff --git a/games-fps/alephone/files/digest-alephone-20051119 b/games-fps/alephone/files/digest-alephone-20051119
new file mode 100644
index 000000000000..f750b4136b10
--- /dev/null
+++ b/games-fps/alephone/files/digest-alephone-20051119
@@ -0,0 +1 @@
+MD5 35d42aa80d3d2ab54b5ec5015e5ddcf4 AlephOne-20051119.tar.gz 6519469