summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-10-13 16:44:47 +0000
committerMichał Górny <mgorny@gentoo.org>2014-10-13 16:44:47 +0000
commit4ba5bc00f3cdaec28a7f08d4b2d2cef22caffe4f (patch)
tree2ee78fc85ac6fd1146d843a9aadac6b6ee510618 /games-fps
parentSupport multilib providers for deps. Bump to EAPI=5. (diff)
downloadgentoo-2-4ba5bc00f3cdaec28a7f08d4b2d2cef22caffe4f.tar.gz
gentoo-2-4ba5bc00f3cdaec28a7f08d4b2d2cef22caffe4f.tar.bz2
gentoo-2-4ba5bc00f3cdaec28a7f08d4b2d2cef22caffe4f.zip
Support multilib providers for deps. Bump to EAPI=5.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/rtcw/ChangeLog5
-rw-r--r--games-fps/rtcw/rtcw-1.41b.ebuild28
2 files changed, 21 insertions, 12 deletions
diff --git a/games-fps/rtcw/ChangeLog b/games-fps/rtcw/ChangeLog
index e96205ac880d..4849c497f7d2 100644
--- a/games-fps/rtcw/ChangeLog
+++ b/games-fps/rtcw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/rtcw
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rtcw/ChangeLog,v 1.43 2014/09/07 17:41:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rtcw/ChangeLog,v 1.44 2014/10/13 16:44:47 mgorny Exp $
+
+ 13 Oct 2014; Michał Górny <mgorny@gentoo.org> rtcw-1.41b.ebuild:
+ Support multilib providers for deps. Bump to EAPI=5.
07 Sep 2014; Ulrich Müller <ulm@gentoo.org> rtcw-1.41b.ebuild:
Drop reverse dependencies of sys-libs/lib-compat to unstable, bug 517932.
diff --git a/games-fps/rtcw/rtcw-1.41b.ebuild b/games-fps/rtcw/rtcw-1.41b.ebuild
index c7674512c8d8..de0ab2b2fdfb 100644
--- a/games-fps/rtcw/rtcw-1.41b.ebuild
+++ b/games-fps/rtcw/rtcw-1.41b.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rtcw/rtcw-1.41b.ebuild,v 1.19 2014/09/07 17:41:03 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rtcw/rtcw-1.41b.ebuild,v 1.20 2014/10/13 16:44:47 mgorny Exp $
-EAPI=2
+EAPI=5
inherit eutils unpacker games
DESCRIPTION="Return to Castle Wolfenstein - Long awaited sequel to Wolfenstein 3D"
@@ -17,14 +17,20 @@ KEYWORDS="~amd64 ~x86"
IUSE="opengl dedicated"
RESTRICT="strip mirror"
-UIDEPEND="virtual/opengl
- x86? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp
- )
- amd64? ( app-emulation/emul-linux-x86-xlibs )"
+UIDEPEND="
+ || (
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )"
RDEPEND="sys-libs/glibc
sys-libs/lib-compat
dedicated? ( app-misc/screen )
@@ -42,7 +48,7 @@ src_install() {
doins -r main Docs pb
exeinto "${dir}"
- doexe bin/Linux/x86/*.x86 openurl.sh || die "copying exe"
+ doexe bin/Linux/x86/*.x86 openurl.sh
games_make_wrapper rtcwmp ./wolf.x86 "${dir}" "${dir}"
games_make_wrapper rtcwsp ./wolfsp.x86 "${dir}" "${dir}"