summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-10-09 23:55:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-10-09 23:55:28 +0000
commitebd3a6b28112f5ec7ef7bb7500cc0ad7c9a1d22d (patch)
tree322776e3944ca3e0fe71d4723229016d34d16808 /games-engines
parentRevert change to postinst behavior in existing ebuild versions. The schema co... (diff)
downloadgentoo-2-ebd3a6b28112f5ec7ef7bb7500cc0ad7c9a1d22d.tar.gz
gentoo-2-ebd3a6b28112f5ec7ef7bb7500cc0ad7c9a1d22d.tar.bz2
gentoo-2-ebd3a6b28112f5ec7ef7bb7500cc0ad7c9a1d22d.zip
build with locale=EE (bug #437488)
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog6
-rw-r--r--games-engines/scummvm/files/scummvm-1.5.0-EE.patch33
-rw-r--r--games-engines/scummvm/scummvm-1.5.0.ebuild7
3 files changed, 43 insertions, 3 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index e9df8e14ff7f..c578bb893b50 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.117 2012/09/08 16:03:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.118 2012/10/09 23:55:28 mr_bones_ Exp $
+
+ 09 Oct 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scummvm-1.5.0-EE.patch, scummvm-1.5.0.ebuild:
+ build with locale=EE (bug #437488)
08 Sep 2012; Michael Sterrett <mr_bones_@gentoo.org> scummvm-1.5.0.ebuild:
fix implicit faad2 dep with patch from Hans (bug #434312)
diff --git a/games-engines/scummvm/files/scummvm-1.5.0-EE.patch b/games-engines/scummvm/files/scummvm-1.5.0-EE.patch
new file mode 100644
index 000000000000..47332df16dee
--- /dev/null
+++ b/games-engines/scummvm/files/scummvm-1.5.0-EE.patch
@@ -0,0 +1,33 @@
+diff -ru scummvm-1.5.0.orig/config.guess scummvm-1.5.0/config.guess
+--- scummvm-1.5.0.orig/config.guess 2012-05-31 06:39:11.000000000 -0400
++++ scummvm-1.5.0/config.guess 2012-10-07 21:27:00.510982188 -0400
+@@ -855,7 +855,7 @@
+ exit ;;
+ *:GNU/*:*:*)
+ # other systems with GNU libc and userland
+- echo ${UNAME_MACHINE}-unknown-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[A-Z]' '[a-z]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-gnu
++ echo ${UNAME_MACHINE}-unknown-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[:upper:]' '[:lower:]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-gnu
+ exit ;;
+ i*86:Minix:*:*)
+ echo ${UNAME_MACHINE}-pc-minix
+@@ -955,7 +955,7 @@
+ exit ;;
+ parisc:Linux:*:* | hppa:Linux:*:*)
+ # Look for CPU level
+- case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
++ case `grep '^cpu[^[:lower:]]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
+ PA7*) echo hppa1.1-unknown-linux-gnu ;;
+ PA8*) echo hppa2.0-unknown-linux-gnu ;;
+ *) echo hppa-unknown-linux-gnu ;;
+diff -ru scummvm-1.5.0.orig/configure scummvm-1.5.0/configure
+--- scummvm-1.5.0.orig/configure 2012-10-07 21:21:27.856337073 -0400
++++ scummvm-1.5.0/configure 2012-10-07 21:26:08.689750153 -0400
+@@ -3897,7 +3897,7 @@
+ fi
+
+ # Save the settings
+- defname="ENABLE_`echo $engine | tr '[a-z]' '[A-Z]'`"
++ defname="ENABLE_`echo $engine | tr '[:lower:]' '[:upper:]'`"
+ if test "$isbuilt" = "no" ; then
+ add_line_to_config_mk "# $defname"
+ else
diff --git a/games-engines/scummvm/scummvm-1.5.0.ebuild b/games-engines/scummvm/scummvm-1.5.0.ebuild
index 8f55453122a5..c3799aa811a8 100644
--- a/games-engines/scummvm/scummvm-1.5.0.ebuild
+++ b/games-engines/scummvm/scummvm-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.5.0.ebuild,v 1.4 2012/09/08 16:03:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.5.0.ebuild,v 1.5 2012/10/09 23:55:28 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="aac alsa debug flac fluidsynth truetype mp3 vorbis"
+IUSE="aac alsa debug flac fluidsynth mp3 opengl truetype vorbis"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND=">=media-libs/libsdl-1.2.2[audio,joystick,video]
@@ -22,6 +22,7 @@ RDEPEND=">=media-libs/libsdl-1.2.2[audio,joystick,video]
alsa? ( media-libs/alsa-lib )
mp3? ( media-libs/libmad )
flac? ( media-libs/flac )
+ opengl? ( virtual/opengl )
truetype? ( media-libs/freetype:2 )
fluidsynth? ( media-sound/fluidsynth )"
DEPEND="${RDEPEND}
@@ -39,6 +40,7 @@ src_prepare() {
-e '/INSTALL.*\/pixmaps/d' \
-e 's/-s //' \
ports.mk || die
+ epatch "${FILESDIR}"/${P}-EE.patch
}
src_configure() {
@@ -64,6 +66,7 @@ src_configure() {
$(use_enable alsa) \
$(use_enable mp3 mad) \
$(use_enable flac) \
+ $(use_enable opengl) \
$(use_enable vorbis) \
$(use_enable truetype freetype2) \
$(use_enable x86 nasm) \