summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2010-11-23 03:21:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2010-11-23 03:21:08 +0000
commit50bf27efa94fc868764404d68bfa1ece355e5902 (patch)
tree23778157a78292b2bc33f41b6a9af9df3760148b /games-engines
parentAdd back ~sparc since it has its ptrace disabled. (diff)
downloadgentoo-2-50bf27efa94fc868764404d68bfa1ece355e5902.tar.gz
gentoo-2-50bf27efa94fc868764404d68bfa1ece355e5902.tar.bz2
gentoo-2-50bf27efa94fc868764404d68bfa1ece355e5902.zip
Install into own datadir subdir
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog7
-rw-r--r--games-engines/scummvm/scummvm-1.2.0-r1.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 1c70fe682230..d0f359b2522e 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.95 2010/10/19 21:38:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.96 2010/11/23 03:21:07 nyhm Exp $
+
+*scummvm-1.2.0-r1 (23 Nov 2010)
+
+ 23 Nov 2010; Tristan Heaven <nyhm@gentoo.org> +scummvm-1.2.0-r1.ebuild:
+ Install into own datadir subdir
*scummvm-1.2.0 (19 Oct 2010)
diff --git a/games-engines/scummvm/scummvm-1.2.0-r1.ebuild b/games-engines/scummvm/scummvm-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..b17362ef8ddb
--- /dev/null
+++ b/games-engines/scummvm/scummvm-1.2.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.2.0-r1.ebuild,v 1.1 2010/11/23 03:21:08 nyhm Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2[audio,joystick,video]
+ >media-libs/libmpeg2-0.3.1
+ sys-libs/zlib
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( media-libs/alsa-lib )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ if use vorbis || use ogg ; then
+ myconf="${myconf} --enable-vorbis"
+ else
+ myconf="${myconf} --disable-vorbis"
+ fi
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ use x86 && append-ldflags -Wl,-z,noexecstack
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ --enable-verbose-build \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}"/${PN} \
+ --libdir="${GAMES_LIBDIR}" \
+ --enable-zlib \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable x86 nasm) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+ doicon icons/scummvm.svg
+ make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"
+ prepgamesdirs
+}