summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-16 02:21:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-16 02:21:35 +0000
commita69340ca105b6e9883675fdbe752c745dae5a49c (patch)
tree78f9c084b9870f806e0d839e79b0d57a26305ed0 /games-emulation
parentMake USE=graph no longer a default. (diff)
downloadgentoo-2-a69340ca105b6e9883675fdbe752c745dae5a49c.tar.gz
gentoo-2-a69340ca105b6e9883675fdbe752c745dae5a49c.tar.bz2
gentoo-2-a69340ca105b6e9883675fdbe752c745dae5a49c.zip
old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hatari/ChangeLog9
-rw-r--r--games-emulation/hatari/files/hatari-1.5.0-gentoo.patch112
-rw-r--r--games-emulation/hatari/files/hatari-1.6.1-gentoo-docdir.patch13
-rw-r--r--games-emulation/hatari/files/hatari-1.6.1-gentoo.patch112
-rw-r--r--games-emulation/hatari/hatari-1.5.0.ebuild67
-rw-r--r--games-emulation/hatari/hatari-1.6.1-r1.ebuild86
-rw-r--r--games-emulation/hatari/hatari-1.6.1.ebuild68
7 files changed, 8 insertions, 459 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index 0bb7535b69f3..4719f880f6c3 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/hatari
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.45 2014/05/15 16:37:13 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.46 2014/07/16 02:21:35 mr_bones_ Exp $
+
+ 16 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/hatari-1.5.0-gentoo.patch, -files/hatari-1.6.1-gentoo-docdir.patch,
+ -files/hatari-1.6.1-gentoo.patch, -hatari-1.5.0.ebuild,
+ -hatari-1.6.1-r1.ebuild, -hatari-1.6.1.ebuild,
+ files/hatari-1.6.2-gentoo-docdir.patch, files/hatari-1.6.2-gentoo.patch:
+ old
15 May 2014; Ulrich Müller <ulm@gentoo.org> hatari-1.5.0.ebuild,
hatari-1.6.1.ebuild, hatari-1.6.1-r1.ebuild, hatari-1.6.2.ebuild:
diff --git a/games-emulation/hatari/files/hatari-1.5.0-gentoo.patch b/games-emulation/hatari/files/hatari-1.5.0-gentoo.patch
deleted file mode 100644
index 4f10d6d9e3ce..000000000000
--- a/games-emulation/hatari/files/hatari-1.5.0-gentoo.patch
+++ /dev/null
@@ -1,112 +0,0 @@
---- hatari-1.4.0.orig/src/paths.c
-+++ hatari-1.4.0/src/paths.c
-@@ -109,71 +109,6 @@
- free(pTmpName);
- }
-
--
--/**
-- * Locate the directory where the hatari executable resides
-- */
--static char *Paths_InitExecDir(const char *argv0)
--{
-- char *psExecDir; /* Path string where the hatari executable can be found */
--
-- /* Allocate memory for storing the path string of the executable */
-- psExecDir = malloc(FILENAME_MAX);
-- if (!psExecDir)
-- {
-- fprintf(stderr, "Out of memory (Paths_Init)\n");
-- exit(-1);
-- }
--
-- /* Determine the bindir...
-- * Start with empty string, then try to use OS specific functions,
-- * and finally analyze the PATH variable if it has not been found yet. */
-- psExecDir[0] = '\0';
--
--#if defined(__linux__)
-- {
-- int i;
-- /* On Linux, we can analyze the symlink /proc/self/exe */
-- i = readlink("/proc/self/exe", psExecDir, FILENAME_MAX);
-- if (i > 0)
-- {
-- char *p;
-- psExecDir[i] = '\0';
-- p = strrchr(psExecDir, '/'); /* Search last slash */
-- if (p)
-- *p = 0; /* Strip file name from path */
-- }
-- }
--//#elif defined(WIN32) || defined(__CEGCC__)
--// /* On Windows we can use GetModuleFileName for getting the exe path */
--// GetModuleFileName(NULL, psExecDir, FILENAME_MAX);
--#endif
--
-- /* If we do not have the execdir yet, analyze argv[0] and the PATH: */
-- if (psExecDir[0] == 0)
-- {
-- if (strchr(argv0, PATHSEP) == 0)
-- {
-- /* No separator in argv[0], we have to explore PATH... */
-- Paths_GetExecDirFromPATH(argv0, psExecDir, FILENAME_MAX);
-- }
-- else
-- {
-- /* There was a path separator in argv[0], so let's assume a
-- * relative or absolute path to the current directory in argv[0] */
-- char *p;
-- strncpy(psExecDir, argv0, FILENAME_MAX);
-- psExecDir[FILENAME_MAX-1] = 0;
-- p = strrchr(psExecDir, PATHSEP); /* Search last slash */
-- if (p)
-- *p = 0; /* Strip file name from path */
-- }
-- }
--
-- return psExecDir;
--}
--
--
- /**
- * Initialize the users home directory string
- * and Hatari's home directory (~/.hatari)
-@@ -226,8 +161,6 @@
- */
- void Paths_Init(const char *argv0)
- {
-- char *psExecDir; /* Path string where the hatari executable can be found */
--
- /* Init working directory string */
- if (getcwd(sWorkingDir, FILENAME_MAX) == NULL)
- {
-@@ -238,27 +171,11 @@
- /* Init the user's home directory string */
- Paths_InitHomeDirs();
-
-- /* Get the directory where the executable resides */
-- psExecDir = Paths_InitExecDir(argv0);
--
-- /* Now create the datadir path name from the bindir path name: */
-- if (psExecDir && strlen(psExecDir) > 0)
-- {
-- snprintf(sDataDir, sizeof(sDataDir), "%s%c%s",
-- psExecDir, PATHSEP, BIN2DATADIR);
-- }
-- else
-- {
-- /* bindir could not be determined, let's assume datadir is relative
-- * to current working directory... */
-- strcpy(sDataDir, BIN2DATADIR);
-- }
-+ strcpy(sDataDir, BIN2DATADIR);
-
- /* And finally make a proper absolute path out of datadir: */
- File_MakeAbsoluteName(sDataDir);
-
-- free(psExecDir);
--
- /* fprintf(stderr, " WorkingDir = %s\n DataDir = %s\n UserHomeDir = %s\n HatariHomeDir = %s\n",
- sWorkingDir, sDataDir, sUserHomeDir, sHatariHomeDir); */
- }
diff --git a/games-emulation/hatari/files/hatari-1.6.1-gentoo-docdir.patch b/games-emulation/hatari/files/hatari-1.6.1-gentoo-docdir.patch
deleted file mode 100644
index 715fb189143f..000000000000
--- a/games-emulation/hatari/files/hatari-1.6.1-gentoo-docdir.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- hatari-1.6.1/python-ui/uihelpers.py
-+++ hatari-1.6.1/python-ui/uihelpers.py
-@@ -97,9 +97,7 @@
- # first try whether there are local Hatari docs in standard place
- # for this Hatari/UI version
- sep = os.sep
-- path = self.get_binary_path("hatari")
-- path = sep.join(path.split(sep)[:-2]) # remove "bin/hatari"
-- path = path + sep + "share" + sep + "doc" + sep + "hatari" + sep
-+ path = "@DOCDIR@"
- if os.path.exists(path + "manual.html"):
- return path
- # if not, point to latest Hatari HG version docs
diff --git a/games-emulation/hatari/files/hatari-1.6.1-gentoo.patch b/games-emulation/hatari/files/hatari-1.6.1-gentoo.patch
deleted file mode 100644
index 4f10d6d9e3ce..000000000000
--- a/games-emulation/hatari/files/hatari-1.6.1-gentoo.patch
+++ /dev/null
@@ -1,112 +0,0 @@
---- hatari-1.4.0.orig/src/paths.c
-+++ hatari-1.4.0/src/paths.c
-@@ -109,71 +109,6 @@
- free(pTmpName);
- }
-
--
--/**
-- * Locate the directory where the hatari executable resides
-- */
--static char *Paths_InitExecDir(const char *argv0)
--{
-- char *psExecDir; /* Path string where the hatari executable can be found */
--
-- /* Allocate memory for storing the path string of the executable */
-- psExecDir = malloc(FILENAME_MAX);
-- if (!psExecDir)
-- {
-- fprintf(stderr, "Out of memory (Paths_Init)\n");
-- exit(-1);
-- }
--
-- /* Determine the bindir...
-- * Start with empty string, then try to use OS specific functions,
-- * and finally analyze the PATH variable if it has not been found yet. */
-- psExecDir[0] = '\0';
--
--#if defined(__linux__)
-- {
-- int i;
-- /* On Linux, we can analyze the symlink /proc/self/exe */
-- i = readlink("/proc/self/exe", psExecDir, FILENAME_MAX);
-- if (i > 0)
-- {
-- char *p;
-- psExecDir[i] = '\0';
-- p = strrchr(psExecDir, '/'); /* Search last slash */
-- if (p)
-- *p = 0; /* Strip file name from path */
-- }
-- }
--//#elif defined(WIN32) || defined(__CEGCC__)
--// /* On Windows we can use GetModuleFileName for getting the exe path */
--// GetModuleFileName(NULL, psExecDir, FILENAME_MAX);
--#endif
--
-- /* If we do not have the execdir yet, analyze argv[0] and the PATH: */
-- if (psExecDir[0] == 0)
-- {
-- if (strchr(argv0, PATHSEP) == 0)
-- {
-- /* No separator in argv[0], we have to explore PATH... */
-- Paths_GetExecDirFromPATH(argv0, psExecDir, FILENAME_MAX);
-- }
-- else
-- {
-- /* There was a path separator in argv[0], so let's assume a
-- * relative or absolute path to the current directory in argv[0] */
-- char *p;
-- strncpy(psExecDir, argv0, FILENAME_MAX);
-- psExecDir[FILENAME_MAX-1] = 0;
-- p = strrchr(psExecDir, PATHSEP); /* Search last slash */
-- if (p)
-- *p = 0; /* Strip file name from path */
-- }
-- }
--
-- return psExecDir;
--}
--
--
- /**
- * Initialize the users home directory string
- * and Hatari's home directory (~/.hatari)
-@@ -226,8 +161,6 @@
- */
- void Paths_Init(const char *argv0)
- {
-- char *psExecDir; /* Path string where the hatari executable can be found */
--
- /* Init working directory string */
- if (getcwd(sWorkingDir, FILENAME_MAX) == NULL)
- {
-@@ -238,27 +171,11 @@
- /* Init the user's home directory string */
- Paths_InitHomeDirs();
-
-- /* Get the directory where the executable resides */
-- psExecDir = Paths_InitExecDir(argv0);
--
-- /* Now create the datadir path name from the bindir path name: */
-- if (psExecDir && strlen(psExecDir) > 0)
-- {
-- snprintf(sDataDir, sizeof(sDataDir), "%s%c%s",
-- psExecDir, PATHSEP, BIN2DATADIR);
-- }
-- else
-- {
-- /* bindir could not be determined, let's assume datadir is relative
-- * to current working directory... */
-- strcpy(sDataDir, BIN2DATADIR);
-- }
-+ strcpy(sDataDir, BIN2DATADIR);
-
- /* And finally make a proper absolute path out of datadir: */
- File_MakeAbsoluteName(sDataDir);
-
-- free(psExecDir);
--
- /* fprintf(stderr, " WorkingDir = %s\n DataDir = %s\n UserHomeDir = %s\n HatariHomeDir = %s\n",
- sWorkingDir, sDataDir, sUserHomeDir, sHatariHomeDir); */
- }
diff --git a/games-emulation/hatari/hatari-1.5.0.ebuild b/games-emulation/hatari/hatari-1.5.0.ebuild
deleted file mode 100644
index 4c143bd4bf3c..000000000000
--- a/games-emulation/hatari/hatari-1.5.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-1.5.0.ebuild,v 1.8 2014/05/15 16:37:13 ulm Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs cmake-utils games
-
-DESCRIPTION="Atari ST emulator"
-HOMEPAGE="http://hatari.berlios.de/"
-SRC_URI="mirror://berlios/hatari/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[X,sound,video]
- sys-libs/readline
- media-libs/libpng
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- games-emulation/emutos"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- # build with newer zlib (bug #387829)
- sed -i -e '1i#define OF(x) x' src/includes/unzip.h || die
- rm -f doc/CMakeLists.txt
-}
-
-src_configure() {
- mycmakeargs=(
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DCMAKE_BUILD_TYPE:STRING=Release"
- "-DDATADIR=${GAMES_DATADIR}/${PN}"
- "-DBIN2DATADIR=${GAMES_DATADIR}/${PN}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DMANDIR=/usr/share/man/man1"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- DOCS="readme.txt doc/*.txt" cmake-utils_src_install
- dohtml -r doc/
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
- elog "has been installed in $(games_get_libdir) with a .img extension (there"
- elog "are several from which to choose)."
- elog
- elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
- elog " http://www.atari.st/"
- elog
- elog "The first time you run hatari, you should configure it to find the"
- elog "TOS you prefer to use. Be sure to save your settings."
- echo
-}
diff --git a/games-emulation/hatari/hatari-1.6.1-r1.ebuild b/games-emulation/hatari/hatari-1.6.1-r1.ebuild
deleted file mode 100644
index 35289d6f5356..000000000000
--- a/games-emulation/hatari/hatari-1.6.1-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-1.6.1-r1.ebuild,v 1.2 2014/05/15 16:37:13 ulm Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_6 python2_7 )
-inherit eutils toolchain-funcs cmake-utils python-single-r1 games
-
-DESCRIPTION="Atari ST emulator"
-HOMEPAGE="http://hatari.berlios.de/"
-SRC_URI="http://download.tuxfamily.org/hatari/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- media-libs/libsdl[X,sound,video]
- sys-libs/readline
- media-libs/libpng
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- dev-python/pygtk[${PYTHON_USEDEP}]
- games-emulation/emutos"
-
-pkg_setup() {
- games_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-gentoo-docdir.patch
- # build with newer zlib (bug #387829)
- sed -i -e '1i#define OF(x) x' src/includes/unzip.h || die
- sed -i -e '/Encoding/d' ./python-ui/hatariui.desktop || die
- sed -i -e "s/python/${EPYTHON}/" tools/atari-hd-image.sh || die
- sed -i \
- -e "s%conf=.*$%conf=\"${GAMES_SYSCONFDIR}\"%" \
- -e "s%path=.*$%path=\"${GAMES_DATADIR}/${PN}/hatariui\"%" \
- python-ui/hatariui || die
- sed -i -e "s#@DOCDIR@#/usr/share/doc/${PF}/html/#" python-ui/uihelpers.py || die
- rm -f doc/CMakeLists.txt
-}
-
-src_configure() {
- mycmakeargs=(
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DCMAKE_BUILD_TYPE:STRING=Release"
- "-DDATADIR=${GAMES_DATADIR}/${PN}"
- "-DBIN2DATADIR=${GAMES_DATADIR}/${PN}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DMANDIR=/usr/share/man/man1"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- DOCS="readme.txt doc/*.txt" cmake-utils_src_install
- dohtml -r doc/
- python_fix_shebang "${ED%/}"/usr/share/games/hatari/{hatariui,hconsole}/*.py
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
- elog "has been installed in $(games_get_libdir) with a .img extension (there"
- elog "are several from which to choose)."
- elog
- elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
- elog " http://www.atari.st/"
- elog
- elog "The first time you run hatari, you should configure it to find the"
- elog "TOS you prefer to use. Be sure to save your settings."
- echo
-}
diff --git a/games-emulation/hatari/hatari-1.6.1.ebuild b/games-emulation/hatari/hatari-1.6.1.ebuild
deleted file mode 100644
index 3685ae03b8d9..000000000000
--- a/games-emulation/hatari/hatari-1.6.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-1.6.1.ebuild,v 1.7 2014/05/15 16:37:13 ulm Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs cmake-utils games
-
-DESCRIPTION="Atari ST emulator"
-HOMEPAGE="http://hatari.berlios.de/"
-SRC_URI="http://download.tuxfamily.org/hatari/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[X,sound,video]
- sys-libs/readline
- media-libs/libpng
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- games-emulation/emutos"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- # build with newer zlib (bug #387829)
- sed -i -e '1i#define OF(x) x' src/includes/unzip.h || die
- sed -i -e '/Encoding/d' ./python-ui/hatariui.desktop || die
- rm -f doc/CMakeLists.txt
-}
-
-src_configure() {
- mycmakeargs=(
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DCMAKE_BUILD_TYPE:STRING=Release"
- "-DDATADIR=${GAMES_DATADIR}/${PN}"
- "-DBIN2DATADIR=${GAMES_DATADIR}/${PN}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DMANDIR=/usr/share/man/man1"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- DOCS="readme.txt doc/*.txt" cmake-utils_src_install
- dohtml -r doc/
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
- elog "has been installed in $(games_get_libdir) with a .img extension (there"
- elog "are several from which to choose)."
- elog
- elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
- elog " http://www.atari.st/"
- elog
- elog "The first time you run hatari, you should configure it to find the"
- elog "TOS you prefer to use. Be sure to save your settings."
- echo
-}