summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-09-21 10:44:04 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-09-21 10:44:04 +0000
commit7921c729212f457772c0e0ba03ff43682fb369cf (patch)
treeae13ba17c0c0174a83b17e81ac49793c6ac3c45f /games-emulation
parentIntroduce botan-bundled useflag as a temp fix for bug #383033 (diff)
downloadgentoo-2-7921c729212f457772c0e0ba03ff43682fb369cf.tar.gz
gentoo-2-7921c729212f457772c0e0ba03ff43682fb369cf.tar.bz2
gentoo-2-7921c729212f457772c0e0ba03ff43682fb369cf.zip
Fix underlink. Bug #379489
Build with sys-libs/zlib-1.2.5.1-r1 (Portage version: 2.1.10.19/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/daphne/ChangeLog9
-rw-r--r--games-emulation/daphne/daphne-1.0.ebuild8
-rw-r--r--games-emulation/daphne/files/daphne-1.0-underlink.patch8
-rw-r--r--games-emulation/daphne/files/daphne-1.0-zlib.patch13
4 files changed, 33 insertions, 5 deletions
diff --git a/games-emulation/daphne/ChangeLog b/games-emulation/daphne/ChangeLog
index c2399ee3f781..996938f3c284 100644
--- a/games-emulation/daphne/ChangeLog
+++ b/games-emulation/daphne/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/daphne
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.16 2010/10/05 07:42:25 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.17 2011/09/21 10:44:04 tupone Exp $
+
+ 21 Sep 2011; Tupone Alfredo <tupone@gentoo.org> daphne-1.0.ebuild,
+ +files/daphne-1.0-underlink.patch, +files/daphne-1.0-zlib.patch:
+ Fix underlink. Bug #379489 by Diego Elio Pettenò
+ Build with sys-libs/zlib-1.2.5.1-r1
05 Oct 2010; Tupone Alfredo <tupone@gentoo.org> daphne-1.0.ebuild,
+files/daphne-1.0-ldflags.patch:
diff --git a/games-emulation/daphne/daphne-1.0.ebuild b/games-emulation/daphne/daphne-1.0.ebuild
index eb60a0a4dc48..bd6e7d43254a 100644
--- a/games-emulation/daphne/daphne-1.0.ebuild
+++ b/games-emulation/daphne/daphne-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.6 2010/10/12 06:02:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.7 2011/09/21 10:44:04 tupone Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -30,7 +30,9 @@ src_prepare() {
epatch "${FILESDIR}/${P}"-typefix.patch
epatch "${FILESDIR}/${P}"-gcc43.patch \
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-zlib.patch \
+ "${FILESDIR}"/${P}-underlink.patch
sed -i "/m_appdir =/s:\.:${GAMES_DATADIR}/${PN}:" \
io/homedir.cpp \
diff --git a/games-emulation/daphne/files/daphne-1.0-underlink.patch b/games-emulation/daphne/files/daphne-1.0-underlink.patch
new file mode 100644
index 000000000000..f04f3f6c5fd1
--- /dev/null
+++ b/games-emulation/daphne/files/daphne-1.0-underlink.patch
@@ -0,0 +1,8 @@
+--- Makefile.vars.linux_x86.old 2011-09-21 12:27:42.480566742 +0200
++++ Makefile.vars.linux_x86 2011-09-21 12:27:57.490564959 +0200
+@@ -24,4 +24,4 @@
+ -DUSE_MMX -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DUSE_OPENGL
+
+ # platform-specific lib flags
+-LIBS = `sdl-config --libs` -ldl -lz -logg -lvorbis -lvorbisfile -lGLEW
++LIBS = `sdl-config --libs` -ldl -lz -logg -lvorbis -lvorbisfile -lGLEW -lGL -lm
diff --git a/games-emulation/daphne/files/daphne-1.0-zlib.patch b/games-emulation/daphne/files/daphne-1.0-zlib.patch
new file mode 100644
index 000000000000..dbae7b31fe9c
--- /dev/null
+++ b/games-emulation/daphne/files/daphne-1.0-zlib.patch
@@ -0,0 +1,13 @@
+--- io/unzip.h.old 2011-09-21 12:13:28.911668053 +0200
++++ io/unzip.h 2011-09-21 12:14:53.074658064 +0200
+@@ -57,6 +57,10 @@
+ #include "zlib.h"
+ #endif
+
++#ifndef OF
++#define OF _Z_OF
++#endif
++
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
+ from (void*) without cast */