summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-24 05:48:48 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-24 05:48:48 +0000
commit54c3cb7871839fbbdf8aefcc7dfa1b5856c0f00a (patch)
treea071d7dd45b303f00666bb9236381258bc6147d1 /games-emulation
parentVersion Bump (diff)
downloadgentoo-2-54c3cb7871839fbbdf8aefcc7dfa1b5856c0f00a.tar.gz
gentoo-2-54c3cb7871839fbbdf8aefcc7dfa1b5856c0f00a.tar.bz2
gentoo-2-54c3cb7871839fbbdf8aefcc7dfa1b5856c0f00a.zip
Use minizip from system zlib #383845 by Dennis Schridde.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus/ChangeLog6
-rw-r--r--games-emulation/mupen64plus/files/mupen64plus-1.5-minizip.patch35
-rw-r--r--games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild7
3 files changed, 45 insertions, 3 deletions
diff --git a/games-emulation/mupen64plus/ChangeLog b/games-emulation/mupen64plus/ChangeLog
index 4ed7aac33651..1aaf29aa14e7 100644
--- a/games-emulation/mupen64plus/ChangeLog
+++ b/games-emulation/mupen64plus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64plus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.14 2011/07/13 06:55:27 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/ChangeLog,v 1.15 2011/09/24 05:48:48 vapier Exp $
+
+ 24 Sep 2011; Mike Frysinger <vapier@gentoo.org> mupen64plus-1.5-r2.ebuild,
+ +files/mupen64plus-1.5-minizip.patch:
+ Use minizip from system zlib #383845 by Dennis Schridde.
13 Jul 2011; Tupone Alfredo <tupone@gentoo.org>
files/mupen64plus-1.5-gcc46.patch:
diff --git a/games-emulation/mupen64plus/files/mupen64plus-1.5-minizip.patch b/games-emulation/mupen64plus/files/mupen64plus-1.5-minizip.patch
new file mode 100644
index 000000000000..9ed3d7a0b256
--- /dev/null
+++ b/games-emulation/mupen64plus/files/mupen64plus-1.5-minizip.patch
@@ -0,0 +1,35 @@
+use minizip from system zlib
+
+https://bugs.gentoo.org/383845
+
+--- a/Makefile
++++ b/Makefile
+@@ -101,8 +101,6 @@
+ main/plugin.o \
+ main/rom.o \
+ main/savestates.o \
+- main/zip/ioapi.o \
+- main/zip/unzip.o \
+ main/7zip/7zAlloc.o \
+ main/7zip/7zBuffer.o \
+ main/7zip/7zCrc.o \
+@@ -229,7 +227,7 @@
+ # set primary objects and libraries for all outputs
+ ALL = mupen64plus $(PLUGINS)
+ OBJECTS = $(OBJ_CORE) $(OBJ_DYNAREC) $(OBJ_OPENGL)
+-LIBS = $(SDL_LIBS) $(LIBGL_LIBS) $(LZMA_LIBS) -lbz2
++LIBS = $(SDL_LIBS) $(LIBGL_LIBS) $(LZMA_LIBS) -lbz2 -lminizip
+ STATIC_LIBS =
+ CFLAGS+= $(LZMA_FLAGS)
+
+--- a/main/rom.c
++++ b/main/rom.c
+@@ -27,7 +27,7 @@
+ #include <limits.h>
+ #include <zlib.h>
+
+-#include "zip/unzip.h"
++#include "minizip/unzip.h"
+ #include <bzlib.h>
+ #include <lzma.h>
+ #include "7zip/7zExtract.h"
diff --git a/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild b/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
index f49e897ef973..81c08ac5f16a 100644
--- a/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
+++ b/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild,v 1.2 2011/04/15 11:45:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus/mupen64plus-1.5-r2.ebuild,v 1.3 2011/09/24 05:48:48 vapier Exp $
EAPI="2"
@@ -26,7 +26,7 @@ RDEPEND="virtual/opengl
media-libs/libsdl
media-libs/sdl-ttf
media-fonts/dejavu
- sys-libs/zlib
+ sys-libs/zlib[minizip]
x11-libs/gtk+:2
libsamplerate? ( media-libs/libsamplerate )
lirc? ( app-misc/lirc )
@@ -54,6 +54,9 @@ src_prepare() {
EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" \
epatch
+ rm -rf main/zip
+ epatch "${FILESDIR}"/${P}-minizip.patch #383845
+
sed -i \
-e "s:/usr/local/share/mupen64plus:${GAMES_DATADIR}/mupen64plus:" \
-e "s:%PUT_PLUGIN_PATH_HERE%:$(games_get_libdir)/${PN}/plugins/:" \