summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-21 08:00:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-21 08:00:01 +0000
commit480037bc6f75902c55d1884c35721b80e1ebd78c (patch)
tree3d4aae7dead9d35d25a08a0a386ed8e7c7c445ff /games-emulation
parentVersion bump to 10.5.0_rc1. (diff)
downloadgentoo-2-480037bc6f75902c55d1884c35721b80e1ebd78c.tar.gz
gentoo-2-480037bc6f75902c55d1884c35721b80e1ebd78c.tar.bz2
gentoo-2-480037bc6f75902c55d1884c35721b80e1ebd78c.zip
fix building with USE=-joystick (bug #540764)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dgen-sdl/ChangeLog6
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild9
-rw-r--r--games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch18
3 files changed, 30 insertions, 3 deletions
diff --git a/games-emulation/dgen-sdl/ChangeLog b/games-emulation/dgen-sdl/ChangeLog
index f6123cd6c547..9712736e9098 100644
--- a/games-emulation/dgen-sdl/ChangeLog
+++ b/games-emulation/dgen-sdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dgen-sdl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.24 2015/02/19 01:48:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.25 2015/02/21 08:00:01 mr_bones_ Exp $
+
+ 21 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/dgen-sdl-1.33-joystick.patch, dgen-sdl-1.33.ebuild:
+ fix building with USE=-joystick (bug #540764)
19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> -dgen-sdl-1.32.ebuild:
old
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
index f71ebff66ca1..5606c8f5841e 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild,v 1.1 2015/02/13 06:24:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild,v 1.2 2015/02/21 08:00:01 mr_bones_ Exp $
EAPI=5
-inherit games
+inherit eutils games
DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
HOMEPAGE="http://dgen.sourceforge.net/"
@@ -20,6 +20,11 @@ RDEPEND="media-libs/libsdl[joystick?,opengl?]
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
+src_prepare() {
+ # fix building with USE=-joystick
+ epatch "${FILESDIR}"/${P}-joystick.patch
+}
+
src_configure() {
egamesconf \
$(use_enable x86 asm) \
diff --git a/games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch
new file mode 100644
index 000000000000..38cb962b690b
--- /dev/null
+++ b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-joystick.patch
@@ -0,0 +1,18 @@
+--- sdl/sdl.cpp.orig
++++ sdl/sdl.cpp
+@@ -6285,6 +6285,7 @@
+ #endif
+ static unsigned long hide_mouse_when;
+ static bool hide_mouse;
++ bool pressed;
+ #ifdef WITH_JOYSTICK
+ static uint32_t const axis_value[][3] = {
+ // { pressed, [implicitly released ...] }
+@@ -6301,7 +6302,6 @@
+ };
+ unsigned int hat_value_map;
+ intptr_t joypad;
+- bool pressed;
+ #endif
+ uint32_t plist[8];
+ uint32_t rlist[8];