summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-01-19 21:18:42 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-01-19 21:18:42 +0000
commit39adf3503b3a6f8e7987a9ee1bcee811a525296b (patch)
treef41e91cec11b14e06234a2f6faa16cfe5340459c /games-emulation
parentversion bump (diff)
downloadgentoo-2-39adf3503b3a6f8e7987a9ee1bcee811a525296b.tar.gz
gentoo-2-39adf3503b3a6f8e7987a9ee1bcee811a525296b.tar.bz2
gentoo-2-39adf3503b3a6f8e7987a9ee1bcee811a525296b.zip
Fix gcc-4.3 build bug #251130
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/qtvba/ChangeLog8
-rw-r--r--games-emulation/qtvba/files/qtvba-0.2-gcc43.patch23
-rw-r--r--games-emulation/qtvba/qtvba-0.2.ebuild7
3 files changed, 33 insertions, 5 deletions
diff --git a/games-emulation/qtvba/ChangeLog b/games-emulation/qtvba/ChangeLog
index 781d532e77ab..500c876a1a7a 100644
--- a/games-emulation/qtvba/ChangeLog
+++ b/games-emulation/qtvba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/qtvba
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/qtvba/ChangeLog,v 1.6 2008/07/27 21:15:46 carlo Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/qtvba/ChangeLog,v 1.7 2009/01/19 21:18:42 tupone Exp $
+
+ 19 Jan 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/qtvba-0.2-gcc43.patch, qtvba-0.2.ebuild:
+ Fix gcc-4.3 build bug #251130 by flameeyes@gentoo.org
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qtvba-0.2.ebuild:
QA: Get rid of deprecated qt_min_version().
diff --git a/games-emulation/qtvba/files/qtvba-0.2-gcc43.patch b/games-emulation/qtvba/files/qtvba-0.2-gcc43.patch
new file mode 100644
index 000000000000..d679e61949d0
--- /dev/null
+++ b/games-emulation/qtvba/files/qtvba-0.2-gcc43.patch
@@ -0,0 +1,23 @@
+--- qtvba.cpp.old 2009-01-19 22:06:58.000000000 +0100
++++ qtvba.cpp 2009-01-19 22:08:40.000000000 +0100
+@@ -27,7 +27,8 @@
+ #include <qurloperator.h>
+
+ // c++ headers
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+
+ // images
+ #include "logo.xpm"
+--- rom_associate.cpp.old 2009-01-19 22:08:57.000000000 +0100
++++ rom_associate.cpp 2009-01-19 22:10:12.000000000 +0100
+@@ -16,7 +16,7 @@
+ #include <qprocess.h>
+
+ // c++ headers
+-#include <iostream.h>
++#include <iostream>
+
+ // images
+
diff --git a/games-emulation/qtvba/qtvba-0.2.ebuild b/games-emulation/qtvba/qtvba-0.2.ebuild
index c3fd64bb6478..612f9f1cc58a 100644
--- a/games-emulation/qtvba/qtvba-0.2.ebuild
+++ b/games-emulation/qtvba/qtvba-0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/qtvba/qtvba-0.2.ebuild,v 1.7 2008/07/27 21:15:46 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/qtvba/qtvba-0.2.ebuild,v 1.8 2009/01/19 21:18:42 tupone Exp $
EAPI=1
@@ -22,7 +22,8 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-Makefilefix.patch"
+ epatch "${FILESDIR}/${PV}-Makefilefix.patch" \
+ "${FILESDIR}"/${P}-gcc43.patch
}
src_install() {