summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-03 07:47:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-03 07:47:52 +0000
commit2db56d71e2d669a28a9ef3888e9e1df7433f3515 (patch)
tree56d6db0a238d96f6539e5929a053c2630d9447bc /games-emulation
parentrename (diff)
downloadgentoo-2-2db56d71e2d669a28a9ef3888e9e1df7433f3515.tar.gz
gentoo-2-2db56d71e2d669a28a9ef3888e9e1df7433f3515.tar.bz2
gentoo-2-2db56d71e2d669a28a9ef3888e9e1df7433f3515.zip
Fix non-x86 support #87716 by Wormo.
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/psemu-peopssoftgpu/ChangeLog8
-rw-r--r--games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-fix-noxf86vm.patch24
-rw-r--r--games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-makefile-cflags.patch13
-rw-r--r--games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.16.ebuild13
4 files changed, 51 insertions, 7 deletions
diff --git a/games-emulation/psemu-peopssoftgpu/ChangeLog b/games-emulation/psemu-peopssoftgpu/ChangeLog
index 917633b6381d..e2c8e776a484 100644
--- a/games-emulation/psemu-peopssoftgpu/ChangeLog
+++ b/games-emulation/psemu-peopssoftgpu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/psemu-peopssoftgpu
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/ChangeLog,v 1.7 2005/02/19 07:28:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/ChangeLog,v 1.8 2005/04/03 07:47:52 vapier Exp $
+
+ 03 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/psemu-peopssoftgpu-1.16-fix-noxf86vm.patch,
+ +files/psemu-peopssoftgpu-1.16-makefile-cflags.patch,
+ psemu-peopssoftgpu-1.16.ebuild:
+ Fix non-x86 support #87716 by Wormo.
*psemu-peopssoftgpu-1.16 (19 Feb 2005)
diff --git a/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-fix-noxf86vm.patch b/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-fix-noxf86vm.patch
new file mode 100644
index 000000000000..96ffcc9dfa99
--- /dev/null
+++ b/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-fix-noxf86vm.patch
@@ -0,0 +1,24 @@
+Make sure we can compile when video mode switching has been disabled.
+
+http://bugs.gentoo.org/show_bug.cgi?id=87716
+
+By Wormo <@gentoo.org>
+
+--- src/draw.c
++++ src/draw.c
+@@ -3847,6 +3847,7 @@
+ }
+ #endif
+
++#ifdef USE_XF86VM
+ // Selects the mode with the highest vertical refresh frequency
+ // from all modes with resolution iResX and iResY.
+ // Returns -1 if no mode is found.
+@@ -3871,6 +3872,7 @@
+ }
+ return bestmode;
+ }
++#endif
+
+ // Create display
+
diff --git a/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-makefile-cflags.patch b/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-makefile-cflags.patch
new file mode 100644
index 000000000000..0624f0d490db
--- /dev/null
+++ b/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.16-makefile-cflags.patch
@@ -0,0 +1,13 @@
+--- src/makes/plg.mk
++++ src/makes/plg.mk
+@@ -4,1 +4,1 @@
+-CFLAGS = -g -Wall -fPIC -O4 -fomit-frame-pointer -ffast-math $(INCLUDE)
++CFLAGS = -Wall -fPIC $(OPTFLAGS) $(INCLUDE)
+--- src/makes/mk.fpse
++++ src/makes/mk.fpse
+@@ -7,1 +7,1 @@
+-INCLUDE += -I./fpse `gtk-config --cflags`
++INCLUDE += -I./fpse `gtk-config --cflags` `sdl-config --cflags`
+@@ -10,1 +10,1 @@
+-LIBS += -lSDL
++LIBS += `sdl-config --libs`
diff --git a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.16.ebuild b/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.16.ebuild
index b29026ea0150..19d216b370c1 100644
--- a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.16.ebuild
+++ b/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.16.ebuild,v 1.1 2005/02/19 07:28:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.16.ebuild,v 1.2 2005/04/03 07:47:52 vapier Exp $
inherit eutils games
@@ -26,20 +26,21 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
cd "${S}"
- return 0
- epatch "${FILESDIR}/${PV}-makefile-cflags.patch"
+ edos2unix src/makes/mk.fpse
+ epatch "${FILESDIR}"/${P}-makefile-cflags.patch
+ epatch "${FILESDIR}"/${P}-fix-noxf86vm.patch
- if [ "${ARCH}" != "x86" ] ; then
+ if [[ ${ARCH} != "x86" ]] ; then
cd src
sed -i \
-e "s/^CPU = i386/CPU = ${ARCH}/g" \
-e '/^XF86VM =/s:TRUE:FALSE:' makes/mk.x11 \
- || die "sed failed"
+ || die "sed non-x86 failed"
if use sdl ; then
sed -i \
-e "s/OBJECTS.*i386.o//g" \
-e "s/-D__i386__//g" makes/mk.fpse \
- || die "sed failed"
+ || die "sed sdl failed"
fi
fi
}