summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-12-10 01:08:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-12-10 01:08:09 +0000
commit02016c9d76c861fc04e6ec6ee6a546d7fbfb8ebb (patch)
tree5d8bd316fa0f6418b59040d9633e20fdce306a5b /games-emulation
parentcorrected dependencies, removed ia64 keyword (see bugs #198366 and 199481). (diff)
downloadgentoo-2-02016c9d76c861fc04e6ec6ee6a546d7fbfb8ebb.tar.gz
gentoo-2-02016c9d76c861fc04e6ec6ee6a546d7fbfb8ebb.tar.bz2
gentoo-2-02016c9d76c861fc04e6ec6ee6a546d7fbfb8ebb.zip
clean out accidentally packaged .o files
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fbzx/fbzx-1.10.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games-emulation/fbzx/fbzx-1.10.ebuild b/games-emulation/fbzx/fbzx-1.10.ebuild
index b0f6657139cc..fdfff16ae9a5 100644
--- a/games-emulation/fbzx/fbzx-1.10.ebuild
+++ b/games-emulation/fbzx/fbzx-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.10.ebuild,v 1.1 2007/12/08 09:52:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.10.ebuild,v 1.2 2007/12/10 01:08:09 mr_bones_ Exp $
inherit eutils toolchain-funcs games
@@ -29,6 +29,11 @@ src_unpack() {
Makefile || die "sed failed"
}
+src_compile() {
+ rm -f fbzx_fs fbzx *.o # clean out accidentally packaged .o files
+ emake || die
+}
+
src_install() {
dogamesbin fbzx || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}/roms"