summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-27 09:37:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-27 09:37:27 +0000
commita17b6aa955a7de4f82907847ef06744982148588 (patch)
tree6593427e3f08a77c630aa88019978708722b0c44 /games-emulation/mupen64-alsasnd
parentfix X requirement by nas #32447 (diff)
downloadgentoo-2-a17b6aa955a7de4f82907847ef06744982148588.tar.gz
gentoo-2-a17b6aa955a7de4f82907847ef06744982148588.tar.bz2
gentoo-2-a17b6aa955a7de4f82907847ef06744982148588.zip
initial ebuild #32749
Diffstat (limited to 'games-emulation/mupen64-alsasnd')
-rw-r--r--games-emulation/mupen64-alsasnd/ChangeLog8
-rw-r--r--games-emulation/mupen64-alsasnd/files/0.4-gentoo.patch16
-rw-r--r--games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.41
-rw-r--r--games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild46
4 files changed, 71 insertions, 0 deletions
diff --git a/games-emulation/mupen64-alsasnd/ChangeLog b/games-emulation/mupen64-alsasnd/ChangeLog
new file mode 100644
index 000000000000..b0f688f7926c
--- /dev/null
+++ b/games-emulation/mupen64-alsasnd/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-emulation/mupen64-alsasnd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.1 2003/12/27 09:37:27 vapier Exp $
+
+*mupen64-alsasnd-0.4 (27 Dec 2003)
+
+ 27 Dec 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Marcelo Góes <blueboard@terra.com.br> #32749.
diff --git a/games-emulation/mupen64-alsasnd/files/0.4-gentoo.patch b/games-emulation/mupen64-alsasnd/files/0.4-gentoo.patch
new file mode 100644
index 000000000000..1a6481b9e7c3
--- /dev/null
+++ b/games-emulation/mupen64-alsasnd/files/0.4-gentoo.patch
@@ -0,0 +1,16 @@
+--- Makefile.orig 2003-12-27 04:24:26.397424080 -0500
++++ Makefile 2003-12-27 04:25:01.939020936 -0500
+@@ -1,4 +1,3 @@
+-GRAPHICAL_INTERFACE=gtk1
+
+ ifeq ($(GRAPHICAL_INTERFACE),gtk1)
+ GUICFLAGS = -DUSE_GTK `gtk-config --cflags`
+@@ -21,7 +20,7 @@
+ all: $(PLUGIN) instructions
+
+ DEBUGCXXFLAGS = -g -Wall -DDEBUG
+-CXXFLAGS = -DNO_DEBUG -DNDEBUG -O3 -Wall -mcpu=athlon -march=athlon -fomit-frame-pointer -ffast-math -fno-rtti
++CXXFLAGS += -DNO_DEBUG -DNDEBUG -fno-rtti
+ OBJECTS += string.o audio.o snd_plugin.o gui.o
+
+ string.o: string_class.cpp string_class.h
diff --git a/games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.4 b/games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.4
new file mode 100644
index 000000000000..7a7eb943e3ca
--- /dev/null
+++ b/games-emulation/mupen64-alsasnd/files/digest-mupen64-alsasnd-0.4
@@ -0,0 +1 @@
+MD5 4b65325e4d31032cb1fc2c704105fa94 alsa-plugin-0.4fix.tar.bz2 26455
diff --git a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
new file mode 100644
index 000000000000..914476597ec0
--- /dev/null
+++ b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header :$
+
+inherit games eutils
+
+DESCRIPTION="Alsa plugin for the mupen64 N64 emulator"
+HOMEPAGE="http://www.emutalk.net/showthread.php?threadid=16895"
+SRC_URI="alsa-plugin-${PV}fix.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+RESTRICT="fetch"
+
+DEPEND=">=media-libs/alsa-lib-0.9.0
+ || (
+ gtk? ( =x11-libs/gtk+-1* )
+ qt? ( >=x11-libs/qt-3 )
+ )"
+
+S=${WORKDIR}/alsa_plugin
+
+pkg_nofetch() {
+ einfo "Please visit this page to download the tarball:"
+ einfo "http://www.emutalk.net/showpost.php?postid=170173&postcount=12"
+ einfo "Then just put ${A} in ${DISTDIR} !"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+}
+
+src_compile() {
+ use qt && export GRAPHICAL_INTERFACE=qt3
+ use gtk && export GRAPHICAL_INTERFACE=gtk1
+ emake || die "make failed"
+}
+
+src_install() {
+ exeinto ${GAMES_LIBDIR}/mupen64/plugins
+ doexe mupen64_alsasnd-${PV}.so || die "doexe failed"
+ dodoc README
+}