summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-07-04 21:08:43 +0000
committerHanno Böck <hanno@gentoo.org>2010-07-04 21:08:43 +0000
commit1a335e5addc04c6c86fdb8132bdfdb916a641ef4 (patch)
tree06160b724447ca24ec9d8de04d9577eed08dd461 /games-emulation/mednafen
parentMove into unstable. (diff)
downloadgentoo-2-1a335e5addc04c6c86fdb8132bdfdb916a641ef4.tar.gz
gentoo-2-1a335e5addc04c6c86fdb8132bdfdb916a641ef4.tar.bz2
gentoo-2-1a335e5addc04c6c86fdb8132bdfdb916a641ef4.zip
mednafen: re-add gcc 4.5 patch
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/mednafen')
-rw-r--r--games-emulation/mednafen/ChangeLog6
-rw-r--r--games-emulation/mednafen/files/mednafen-0.8.13-gcc45.patch11
-rw-r--r--games-emulation/mednafen/mednafen-0.8.13.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/games-emulation/mednafen/ChangeLog b/games-emulation/mednafen/ChangeLog
index 421148190046..71b5cc923c18 100644
--- a/games-emulation/mednafen/ChangeLog
+++ b/games-emulation/mednafen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mednafen
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.22 2010/07/02 07:49:20 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.23 2010/07/04 21:08:43 hanno Exp $
+
+ 04 Jul 2010; Hanno Boeck <hanno@gentoo.org> mednafen-0.8.13.ebuild,
+ +files/mednafen-0.8.13-gcc45.patch:
+ Re-add gcc 4.5 patch.
*mednafen-0.8.13 (02 Jul 2010)
diff --git a/games-emulation/mednafen/files/mednafen-0.8.13-gcc45.patch b/games-emulation/mednafen/files/mednafen-0.8.13-gcc45.patch
new file mode 100644
index 000000000000..2ab5e9c7c85d
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.8.13-gcc45.patch
@@ -0,0 +1,11 @@
+--- src/pcfx/soundbox.cpp.old 2010-05-24 11:15:20.000000000 +0200
++++ src/pcfx/soundbox.cpp 2010-05-24 11:15:36.000000000 +0200
+@@ -416,7 +416,7 @@
+ int rolloff = (int)((double)0.90 * 21477272 * 2 / 1365 / (1 << SampleFreq) ) / 2;
+ for(int ch = 0; ch < 2; ch++)
+ for(int lr = 0; lr < 2; lr++)
+- ADPCMSynth[ch][lr].treble_eq(blip_eq_t::blip_eq_t(-1000, rolloff, FSettings.SndRate));
++ ADPCMSynth[ch][lr].treble_eq(blip_eq_t(-1000, rolloff, FSettings.SndRate));
+ LSampleFreq = SampleFreq;
+ }
+ }
diff --git a/games-emulation/mednafen/mednafen-0.8.13.ebuild b/games-emulation/mednafen/mednafen-0.8.13.ebuild
index 17b005c4c1c5..fe1fd5c1fb35 100644
--- a/games-emulation/mednafen/mednafen-0.8.13.ebuild
+++ b/games-emulation/mednafen/mednafen-0.8.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.8.13.ebuild,v 1.1 2010/07/02 07:49:20 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.8.13.ebuild,v 1.2 2010/07/04 21:08:43 hanno Exp $
EAPI=2
inherit autotools eutils games
@@ -39,6 +39,7 @@ src_prepare() {
-e '/-ffast-math/d' \
configure.ac \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-gcc45.patch
eautoreconf
}