summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 21:20:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 21:20:21 +0000
commit51c45ba642fe1b449b01c4162fba78d4af968a64 (patch)
treeebea17067c6da9d513c43d8614294f14893b9ad0 /games-emulation/hatari/hatari-0.90.ebuild
parentversion bump (diff)
downloadgentoo-2-51c45ba642fe1b449b01c4162fba78d4af968a64.tar.gz
gentoo-2-51c45ba642fe1b449b01c4162fba78d4af968a64.tar.bz2
gentoo-2-51c45ba642fe1b449b01c4162fba78d4af968a64.zip
version bump (bug #149757)
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-emulation/hatari/hatari-0.90.ebuild')
-rw-r--r--games-emulation/hatari/hatari-0.90.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-emulation/hatari/hatari-0.90.ebuild b/games-emulation/hatari/hatari-0.90.ebuild
new file mode 100644
index 000000000000..e8fcbab07a13
--- /dev/null
+++ b/games-emulation/hatari/hatari-0.90.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.90.ebuild,v 1.1 2006/10/01 21:20:21 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ games-emulation/emutos"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^CC/d' \
+ -e "/^CFLAGS/ s:=.*:=${CFLAGS}:" \
+ -e "/^DATADIR/ s:=.*:= ${GAMES_DATADIR}/${PN}:" Makefile.cnf \
+ || die "sed Makefile.cnf failed"
+}
+
+src_compile() {
+ # broken deps in the makefiles
+ emake -C src/uae-cpu gencpu || die "emake failed"
+ emake -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
+ || die "doins failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ einfo "has been installed in /usr/games/lib/ with a .img extension (there"
+ einfo "are several from which to choose)."
+ echo
+ einfo "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ einfo " http://www.atari.st/"
+ echo
+ einfo "The first time you run hatari, you should configure it to find the"
+ einfo "TOS you prefer to use. Be sure to save your settings."
+ echo
+}