summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-18 07:28:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-18 07:28:58 +0000
commitd99b733fcac6cb1b0bdb40efc258e6417adb6e63 (patch)
tree769a1dee4e29210a2954e0785e8a56590cb9eecb /games-emulation/dosbox
parentversion bump (diff)
downloadgentoo-2-d99b733fcac6cb1b0bdb40efc258e6417adb6e63.tar.gz
gentoo-2-d99b733fcac6cb1b0bdb40efc258e6417adb6e63.tar.bz2
gentoo-2-d99b733fcac6cb1b0bdb40efc258e6417adb6e63.zip
removed the depend on ncurses since we don't use the debugger
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/ChangeLog6
-rw-r--r--games-emulation/dosbox/Manifest4
-rw-r--r--games-emulation/dosbox/dosbox-0.60.ebuild11
3 files changed, 15 insertions, 6 deletions
diff --git a/games-emulation/dosbox/ChangeLog b/games-emulation/dosbox/ChangeLog
index bbc60389a871..5175050d59ae 100644
--- a/games-emulation/dosbox/ChangeLog
+++ b/games-emulation/dosbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dosbox
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.3 2003/10/16 22:34:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.4 2003/10/18 07:28:56 mr_bones_ Exp $
+
+ 18 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> dosbox-0.60.ebuild:
+ removed the depend on ncurses since we don't use the debugger; added
+ src_compile
*dosbox-0.60 (16 Oct 2003)
diff --git a/games-emulation/dosbox/Manifest b/games-emulation/dosbox/Manifest
index 1c45ac01a4c3..5bdc1f947759 100644
--- a/games-emulation/dosbox/Manifest
+++ b/games-emulation/dosbox/Manifest
@@ -1,7 +1,7 @@
-MD5 32adb029b4993364c08b9294c371a8e5 ChangeLog 702
+MD5 e98013a33df4017b6358afc05ed33e12 ChangeLog 863
MD5 167e070338162f10662b76153c0f1168 dosbox-0.57.ebuild 652
MD5 a763cf73f6bb800b4f215de7b0751923 dosbox-0.58.ebuild 604
-MD5 b3fe5501dbc664dc044a25924624902f dosbox-0.60.ebuild 738
+MD5 cbcee8b4c69709c3082a6258346895dd dosbox-0.60.ebuild 805
MD5 0cb11f37c15336741cffc1543fd25f56 files/digest-dosbox-0.57 63
MD5 709911d69c3fb90908508f4c3116a07f files/digest-dosbox-0.58 63
MD5 a15acc3d9f2a2d55bde29cf697f86297 files/digest-dosbox-0.60 63
diff --git a/games-emulation/dosbox/dosbox-0.60.ebuild b/games-emulation/dosbox/dosbox-0.60.ebuild
index 0f165c2c98eb..4f6cc7fb2962 100644
--- a/games-emulation/dosbox/dosbox-0.60.ebuild
+++ b/games-emulation/dosbox/dosbox-0.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.60.ebuild,v 1.1 2003/10/16 22:34:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.60.ebuild,v 1.2 2003/10/18 07:28:56 mr_bones_ Exp $
inherit games
@@ -14,12 +14,17 @@ SLOT="0"
IUSE="alsa ncurses png"
-DEPEND="ncurses? ( sys-libs/ncurses )
- png? ( media-libs/libpng sys-libs/zlib )
+DEPEND="png? ( media-libs/libpng sys-libs/zlib )
alsa? ( media-libs/alsa-lib )
media-libs/sdl-net
>=media-libs/libsdl-1.2.0"
+src_compile() {
+ egamesconf \
+ `use_enable alsa alsatest` || die
+ emake || die "emake failed"
+}
+
src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS