summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-12-17 00:43:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-12-17 00:43:33 +0000
commitceaf594fc859b3c73f6cbfb1048d78e2199f7fcb (patch)
treea964d16b68a55fd4096711bbf0e55bd11a840e7a /games-board
parentEAPI=5 (diff)
downloadgentoo-2-ceaf594fc859b3c73f6cbfb1048d78e2199f7fcb.tar.gz
gentoo-2-ceaf594fc859b3c73f6cbfb1048d78e2199f7fcb.tar.bz2
gentoo-2-ceaf594fc859b3c73f6cbfb1048d78e2199f7fcb.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gtkatlantic/ChangeLog8
-rw-r--r--games-board/gtkatlantic/gtkatlantic-0.5.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/games-board/gtkatlantic/ChangeLog b/games-board/gtkatlantic/ChangeLog
index 96b77c4558c5..9d2f66df3483 100644
--- a/games-board/gtkatlantic/ChangeLog
+++ b/games-board/gtkatlantic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/gtkatlantic
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gtkatlantic/ChangeLog,v 1.23 2014/03/20 20:36:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gtkatlantic/ChangeLog,v 1.24 2014/12/17 00:43:33 mr_bones_ Exp $
+
+*gtkatlantic-0.5.0 (17 Dec 2014)
+
+ 17 Dec 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +gtkatlantic-0.5.0.ebuild:
+ version bump
20 Mar 2014; Michael Sterrett <mr_bones_@gentoo.org>
-files/gtkatlantic-0.4.2-libpng14.patch, -gtkatlantic-0.4.2.ebuild:
diff --git a/games-board/gtkatlantic/gtkatlantic-0.5.0.ebuild b/games-board/gtkatlantic/gtkatlantic-0.5.0.ebuild
new file mode 100644
index 000000000000..e8891388704b
--- /dev/null
+++ b/games-board/gtkatlantic/gtkatlantic-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gtkatlantic/gtkatlantic-0.5.0.ebuild,v 1.1 2014/12/17 00:43:33 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Monopoly-like game that works with the monopd server"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/downloads/v0.5/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:3
+ dev-libs/libxml2
+ media-libs/libpng:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ newicon data/icon32x32.xpm ${PN}.xpm
+ newicon -s 16 data/icon16x16.xpm ${PN}.xpm
+ newicon -s 32 data/icon32x32.xpm ${PN}.xpm
+ make_desktop_entry ${PN} GtkAtlantic
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}