summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-12-28 00:59:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-12-28 00:59:28 +0000
commit79a5c37969ce8c77ea7067d20c2a19c8049e2bf4 (patch)
tree2d3e0d89d5695782ecad8e14c095543583c0b33f /games-board
parentarm/ia64/s390/sh stable (diff)
downloadgentoo-2-79a5c37969ce8c77ea7067d20c2a19c8049e2bf4.tar.gz
gentoo-2-79a5c37969ce8c77ea7067d20c2a19c8049e2bf4.tar.bz2
gentoo-2-79a5c37969ce8c77ea7067d20c2a19c8049e2bf4.zip
Install desktop entry, bug #159205
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mah-jong/ChangeLog5
-rw-r--r--games-board/mah-jong/mah-jong-1.7.ebuild16
2 files changed, 15 insertions, 6 deletions
diff --git a/games-board/mah-jong/ChangeLog b/games-board/mah-jong/ChangeLog
index 561d074e5ba1..3d15dc3e52e8 100644
--- a/games-board/mah-jong/ChangeLog
+++ b/games-board/mah-jong/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/mah-jong
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.8 2006/04/23 06:30:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.9 2006/12/28 00:59:28 nyhm Exp $
+
+ 28 Dec 2006; Tristan Heaven <nyhm@gentoo.org> mah-jong-1.7.ebuild:
+ Install desktop entry, bug #159205
*mah-jong-1.7 (23 Apr 2006)
diff --git a/games-board/mah-jong/mah-jong-1.7.ebuild b/games-board/mah-jong/mah-jong-1.7.ebuild
index d3626f78c490..d2690460d697 100644
--- a/games-board/mah-jong/mah-jong-1.7.ebuild
+++ b/games-board/mah-jong/mah-jong-1.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.7.ebuild,v 1.1 2006/04/23 06:30:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.7.ebuild,v 1.2 2006/12/28 00:59:28 nyhm Exp $
-inherit games
+inherit eutils toolchain-funcs games
MY_P="mj-${PV}-src"
DESCRIPTION="A networked Mah Jong program, together with a computer player"
@@ -30,17 +30,23 @@ src_unpack() {
sed -i \
-e "/^DESTDIR =/ s:=.*:= ${D}:" \
-e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
- -e "/^MANDIR =/ s:man/man1:/usr/share/man/man6:" \
- -e "/^MANSUFFIX =/ s:1:6:" \
+ -e '/^MANDIR =/ s:man/man1:/usr/share/man/man6:' \
+ -e '/^MANSUFFIX =/ s:1:6:' \
+ -e "/^CC =/ s:gcc:$(tc-getCC):" \
-e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
+ -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
+ -e '/^INSTPGMFLAGS =/ s:-s::' \
+ -e '/^CDEBUGFLAGS =/d' \
-e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
|| die "sed failed"
}
src_install() {
- make install install.man || die "make install failed"
+ emake install install.man || die "emake install failed"
insinto "${GAMES_DATADIR}/${PN}"
doins -r fallbacktiles/ tiles-numbered/ tiles-small/ || die "doins failed"
+ newicon tiles-v1/tongE.xpm ${PN}.xpm
+ make_desktop_entry xmj Mah-Jong ${PN}.xpm
dodoc CHANGES ChangeLog *.txt
prepgamesdirs
}