summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-12-19 22:05:19 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-12-19 22:05:19 +0000
commit0903c65cf398bcb6753c5a8d783b261b78db6ca2 (patch)
tree4f7e4bfd40da1f397836c418c465030bf885a5f0 /games-board/pioneers
parentamd64 stable, bug #493674 (diff)
downloadgentoo-2-0903c65cf398bcb6753c5a8d783b261b78db6ca2.tar.gz
gentoo-2-0903c65cf398bcb6753c5a8d783b261b78db6ca2.tar.bz2
gentoo-2-0903c65cf398bcb6753c5a8d783b261b78db6ca2.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-board/pioneers')
-rw-r--r--games-board/pioneers/ChangeLog8
-rw-r--r--games-board/pioneers/files/pioneers-15.1-build.patch51
-rw-r--r--games-board/pioneers/metadata.xml3
-rw-r--r--games-board/pioneers/pioneers-15.1.ebuild47
4 files changed, 108 insertions, 1 deletions
diff --git a/games-board/pioneers/ChangeLog b/games-board/pioneers/ChangeLog
index 74e15e125fdd..88d8393cfc51 100644
--- a/games-board/pioneers/ChangeLog
+++ b/games-board/pioneers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/pioneers
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.30 2013/01/24 19:31:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/ChangeLog,v 1.31 2013/12/19 22:05:19 hasufell Exp $
+
+*pioneers-15.1 (19 Dec 2013)
+
+ 19 Dec 2013; Julian Ospald <hasufell@gentoo.org> +pioneers-15.1.ebuild,
+ +files/pioneers-15.1-build.patch, metadata.xml:
+ version bump
24 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -pioneers-0.12.3.ebuild:
old
diff --git a/games-board/pioneers/files/pioneers-15.1-build.patch b/games-board/pioneers/files/pioneers-15.1-build.patch
new file mode 100644
index 000000000000..eab138595a50
--- /dev/null
+++ b/games-board/pioneers/files/pioneers-15.1-build.patch
@@ -0,0 +1,51 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Dec 19 21:30:53 UTC 2013
+
+* add --with-help switch
+* don't use AM_CFLAGS in configure.ac, it is bad form
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -129,12 +129,21 @@
+ *) pioneers_deprecationChecks=no ;;
+ esac])
+
++AC_ARG_WITH([help],
++ AS_HELP_STRING([--with-help],
++ [Enable gnome help via scrollkeeper.]),
++[case "${withval}" in
++ yes) with_help=yes ;;
++ "") with_help=yes ;;
++ *) with_help=no ;;
++esac])
++
+ ## The warnings are in the same order as in 'man gcc'
+ if test "x$GCC" = xyes; then
+ # Flags from Debian hardening (dpkg-buildflags --get CFLAGS)
+- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security"])
+- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -D_FORTIFY_SOURCE=2"])
+- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -pie -fPIE"])
++ AC_SUBST(CFLAGS, ["$CFLAGS -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security"])
++ AC_SUBST(CFLAGS, ["$CFLAGS -D_FORTIFY_SOURCE=2"])
++ AC_SUBST(CFLAGS, ["$CFLAGS -pie -fPIE"])
+
+ if test "$pioneers_is_windows_port" = "no"; then
+ # Flags from Debian hardening (dpkg-buildflags --get LDFLAGS)
+@@ -143,7 +152,7 @@
+ fi
+
+ # Only link the directly needed libraries
+- AC_SUBST(AM_CFLAGS, ["$AM_CFLAGS -Wl,--as-needed"])
++ AC_SUBST(CFLAGS, ["$CFLAGS -Wl,--as-needed"])
+
+ if test "$pioneers_warnings" = yes -o "$pioneers_warnings" = full; then
+ AC_SUBST(WARNINGS, "-Wall")
+@@ -385,7 +394,7 @@
+ AM_GLIB_GNU_GETTEXT
+
+ if test $pioneers_is_mingw_port = yes; then
+- AC_SUBST(AM_CFLAGS, "-mms-bitfields $AM_CFLAGS")
++ AC_SUBST(CFLAGS, "-mms-bitfields $CFLAGS")
+ # No console window for the graphical applications
+ AC_SUBST(GTK2_LIBS, "$GTK2_LIBS -mwindows")
+ # Don't use bin, lib and share subdirectories
diff --git a/games-board/pioneers/metadata.xml b/games-board/pioneers/metadata.xml
index 9f9ad7d7f201..da63181d30ef 100644
--- a/games-board/pioneers/metadata.xml
+++ b/games-board/pioneers/metadata.xml
@@ -5,4 +5,7 @@
<longdescription>
Pio (Pioneers) is a clone of the board game The Settlers of Catan.
</longdescription>
+<use>
+ <flag name='help'>Enable gnome ingame help via scrollkeeper</flag>
+</use>
</pkgmetadata>
diff --git a/games-board/pioneers/pioneers-15.1.ebuild b/games-board/pioneers/pioneers-15.1.ebuild
new file mode 100644
index 000000000000..7162d9d9ccd7
--- /dev/null
+++ b/games-board/pioneers/pioneers-15.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/pioneers-15.1.ebuild,v 1.1 2013/12/19 22:05:19 hasufell Exp $
+
+EAPI=5
+inherit autotools eutils gnome-games
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="help nls"
+
+# dev-util/gob only for autoreconf
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/libnotify
+ help? (
+ >=app-text/scrollkeeper-0.3.8
+ >=gnome-base/libgnome-2.10
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/gob:2
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome-games_src_configure \
+ $(use_enable nls) \
+ $(use_with help)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO NEWS" \
+ gnome2_src_install scrollkeeper_localstate_dir="${ED%/}"/var/lib/scrollkeeper/
+ prepgamesdirs
+}