summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-27 15:03:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-27 15:03:01 +0000
commitce838f8953402a5234ec080da62d0533ca5b323d (patch)
tree51bde75681cf8c56bf2d849fb86938fb41ac2c4a /games-board/gnushogi
parentNew package: clamz is a command-line downloader for the Amazon.com MP3 music ... (diff)
downloadgentoo-2-ce838f8953402a5234ec080da62d0533ca5b323d.tar.gz
gentoo-2-ce838f8953402a5234ec080da62d0533ca5b323d.tar.bz2
gentoo-2-ce838f8953402a5234ec080da62d0533ca5b323d.zip
Fix parallel make issue. Bug #298017
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-board/gnushogi')
-rw-r--r--games-board/gnushogi/ChangeLog8
-rw-r--r--games-board/gnushogi/files/gnushogi-1.3-parallel.patch12
-rw-r--r--games-board/gnushogi/gnushogi-1.3.ebuild12
3 files changed, 22 insertions, 10 deletions
diff --git a/games-board/gnushogi/ChangeLog b/games-board/gnushogi/ChangeLog
index da95101a916f..1e5d8bd6989d 100644
--- a/games-board/gnushogi/ChangeLog
+++ b/games-board/gnushogi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/gnushogi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/ChangeLog,v 1.14 2009/12/22 22:15:11 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/ChangeLog,v 1.15 2010/05/27 15:03:01 tupone Exp $
+
+ 27 May 2010; Tupone Alfredo <tupone@gentoo.org> gnushogi-1.3.ebuild,
+ +files/gnushogi-1.3-parallel.patch:
+ Fix parallel make issue. Bug #298017
22 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> gnushogi-1.3.ebuild:
Use -j1 for build (bug #298017).
diff --git a/games-board/gnushogi/files/gnushogi-1.3-parallel.patch b/games-board/gnushogi/files/gnushogi-1.3-parallel.patch
new file mode 100644
index 000000000000..e85c4783372e
--- /dev/null
+++ b/games-board/gnushogi/files/gnushogi-1.3-parallel.patch
@@ -0,0 +1,12 @@
+--- Makefile.in.old 2010-05-27 16:53:34.000000000 +0200
++++ Makefile.in 2010-05-27 16:54:28.000000000 +0200
+@@ -31,7 +31,8 @@
+ # Default targets.
+ #
+
+-all : gnushogi_compile pat2inc gnushogi.bbk @XSHOGI@
++all : @XSHOGI@
++ -cd $(GNUSHOGIDIR); $(MAKE) gnushogi pat2inc gnushogi.bbk
+
+
+ #
diff --git a/games-board/gnushogi/gnushogi-1.3.ebuild b/games-board/gnushogi/gnushogi-1.3.ebuild
index 4a2e8fbe9582..deab26f7b1e4 100644
--- a/games-board/gnushogi/gnushogi-1.3.ebuild
+++ b/games-board/gnushogi/gnushogi-1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.16 2009/12/30 21:16:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.17 2010/05/27 15:03:01 tupone Exp $
EAPI=2
inherit eutils games
@@ -30,7 +30,8 @@ src_prepare() {
|| die "sed ${f} failed"
done
epatch "${FILESDIR}/${PV}-errno.patch" \
- "${FILESDIR}/${P}"-gcc4.patch
+ "${FILESDIR}/${P}"-gcc4.patch \
+ "${FILESDIR}"/${P}-parallel.patch
}
src_configure() {
@@ -40,11 +41,6 @@ src_configure() {
addpredict /usr/games/lib/gnushogi/gnushogi.hsh
}
-src_compile() {
- # bug #298017
- emake -j1 || die "emake failed"
-}
-
src_install() {
dogamesbin gnushogi/gnushogi || die "dogamesbin failed"
if use X ; then