summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-20 17:19:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-20 17:19:39 +0000
commitaa340946e350fffaf66bca856625be7f7b1192f7 (patch)
treef112b60613a6b6a61d7d81caecc8e218254ce9a3 /games-board/domination
parentwhitespace (diff)
downloadgentoo-2-aa340946e350fffaf66bca856625be7f7b1192f7.tar.gz
gentoo-2-aa340946e350fffaf66bca856625be7f7b1192f7.tar.bz2
gentoo-2-aa340946e350fffaf66bca856625be7f7b1192f7.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/domination')
-rw-r--r--games-board/domination/ChangeLog8
-rw-r--r--games-board/domination/domination-1.1.1.2.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/games-board/domination/ChangeLog b/games-board/domination/ChangeLog
index 3144961d9f55..500e61374781 100644
--- a/games-board/domination/ChangeLog
+++ b/games-board/domination/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/domination
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/domination/ChangeLog,v 1.8 2012/10/30 12:01:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/ChangeLog,v 1.9 2012/11/20 17:19:39 mr_bones_ Exp $
+
+*domination-1.1.1.2 (20 Nov 2012)
+
+ 20 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +domination-1.1.1.2.ebuild:
+ version bump
30 Oct 2012; <ago@gentoo.org> domination-1.1.1.1.ebuild:
Stable for amd64, wrt bug #439212
diff --git a/games-board/domination/domination-1.1.1.2.ebuild b/games-board/domination/domination-1.1.1.2.ebuild
new file mode 100644
index 000000000000..043d209dde11
--- /dev/null
+++ b/games-board/domination/domination-1.1.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/domination-1.1.1.2.ebuild,v 1.1 2012/11/20 17:19:39 mr_bones_ Exp $
+
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://domination.sourceforge.net"
+SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+S=${WORKDIR}/Domination
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+EANT_BUILD_TARGET="game"
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ mkdir -p "${D}${GAMES_PREFIX}"/bin
+ cp "${S}"/FlashGUI.sh "${D}${GAMES_PREFIX}"/bin/${PN} || die
+ sed -i \
+ -e "s|cd.*|cd \"${GAMES_DATADIR}\"/${PN}|" \
+ "${D}${GAMES_PREFIX}"/bin/${PN} \
+ || die
+ chmod +x "${D}${GAMES_PREFIX}"/bin/${PN} || die
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r "${S}"/* || die
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd || die
+ java-pkg_regjar "${D}/${GAMES_DATADIR}/${PN}"/*.jar
+
+ newicon resources/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Domination"
+
+ prepgamesdirs
+}